finest1

Members
  • Content count

    233
  • Joined

  • Last visited

  • Days Won

    1

finest1 last won the day on April 5 2014

finest1 had the most liked content!

Community Reputation

3 Neutral

About finest1

  • Rank
    Advanced Member

Contact Methods

  • First Name
    rishi

Profile Information

  • Gender
    Male
  • Lexus Model
    IS250
  • Year of Lexus
    2006
  • UK/Ireland Location
    Greater London

Recent Profile Visitors

8,583 profile views
  1. squealing brakes at low speeds

    thanks for all your replies. brakes are still squealing. @normski2no, didn't do the upstream. car is running really well though when I visit my sister I will do the brakes then, I use her garage
  2. squealing brakes at low speeds

    hi, I tried the above. the car eventually just stops, no jerks or sudden stops. did it on a flat road.
  3. thanks for the replies. just to give you some feedback: I carefully moved the mirror by hand up and down. you will hear a grating noise which sounds worse than it is. I then went inside the car and flicked the L and R mirror switch back and forth a few times. I then put the car on and put in reverse. the mirrors tilted. so I then put the car in park and moved it with the cursor. it worked. but this weekend it went sticky again, so not exactly a fix, but did get it moving again. @Comedian that's a great tip! agree it is not in the manual. I always wondered why it wouldn't tilt fully and how does I cater for taller or shorter people. now we know!! how on earth did you work that out??
  4. squealing brakes at low speeds

    ok I will give this a try I've had the car since 2010. I'm not sure when the pins were checked. it had a service with lexus in july this year
  5. squealing brakes at low speeds

    thanks all, @is200newbie he did check for seized calliper when he changed the front disks. he also checked the rear for seized and found no indication. he also asked to drive slowly down a slope in neutral. if it doesn't roll freely then I have seized caliper. I tried it and it rolled fine
  6. hi all, I have a feature on my IS250 SE-L where as you put it in reverse gear and the mirrors tilt to help you park close to the kerb. my question is , how much should they tilt? my mirrors tilt but not all the way where it sees the kerb. I remember when I first bought the car it did, but I don't really remember. I just rely on the reverse camera. I just want to know if there is an issue surfacing thanks in advance
  7. hi all, how you all doing? I changed my front brake pads on 31/3/2017. actually my local mechanic did it. a month later it was squealing at low speeds 5MPH - 10MPH . the squeal sometimes is real loud! I took it to him to check and grease. he said you don't grease modern brakes. he checked the brake discs and said that the front 2 discs are showing signs of wear. that's fine I hadn't changed them for a while. so we changed them. this was 27/7/2017. squeal gone. a few days later squeal was back. exactly how it was before. I phoned him up and told him. he said this was normal as the brake pads have not adjusted to the new brake discs. the bloody thing is still squealing. I do trust him as he has done work for me in the past and always given me free advice. mmm but I'm not sure. what do you think? thanks in advance
  8. hi all just to close this thread. issue resolved. the power connector was not seated in properly. all working fine now
  9. thanks steve, driving home yesterday I put the radio on. after 10 minutes it cut. I happen to see a friend whilst driving, I pulled over and had a chat. after 5 mins the radio just came back to life ! it stayed on for the duration of the conversation and the journey home! i'll monitor it again today. I might pull the unit out and check the connections are seated properly
  10. hi all, I started to encounter this problem yesterday. the radio cut off after 10 minutes of playing yesterday. I left it overnight and this morning it was working. then after another 10 minutes it turned off. here are some observations: radio plays, receives radio stations, volume works. speakers work but after 10 minutes shuts off no power after turning radio on and off light around on off and vol comes on, but no sound, cd also does not work at this point, does not load when you feed CD in any ideas? thanks in advance
  11. fault code diagnosis help needed

    great thanks, i will let you know how i get on. have you ever changed the spark plugs yourself?
  12. hi all, i hope everyone is well. car: IS250 SE-L 2006 2.5 petrol i had the following lights come up on my display: engine light traction light (car skidding icon RHS of display) and the "check VSC" phrase i have ran it through torque app twice and here is the following: fault codes: P0031 HO2S Heater Control Circuit Low (Bank 1 Sensor 1) i know this to be the 02 sensor . i know there are four, so not sure where this is. im hoping engine bay side P0300 Random/Multiple Cylinder Misfire Detected P0301 Cylinder 1 Misfire Detected P0303 Cylinder 3 Misfire Detected i don't know what these three are. im wondering if it is to do with the spark plugs. i've never changed the spark plugs during my ownership. im wondering if i change these, will this resolve the issue? any advice will be appreicated thanks in advance Rishi (finest1)
  13. O2 sensor - Bank 2, Sensor 1 - Replacement

    amazing tutorial ! but i can't see the photos
  14. i've had my IS250 SE-L since 2010. i love it! only thing i don't like is the boot lid does not open automatically...