K-Lye

Members
  • Content count

    5
  • Joined

  • Last visited

Community Reputation

0 Neutral

About K-Lye

  • Rank
    New Club Member
  • Birthday April 26

Contact Methods

  • First Name
    Michael

Profile Information

  • Gender
    Male
  • Lexus Model
    RX350
  • Year of Lexus
    2007
  • UK/Ireland Location
    Berkshire
  • Interests
    General Automotive
    Motorsport & Racing
    Travel
    Food & Drink
    Computers & Electronics
  1. Hi hope I’ve got the right forum for this. Had a bit of a prang in our RX350 last night. Unfortunately one of those that’s likely a write-off due to the age of the vehicle (2006). It’s completely drivable with some bumper and minor undercarriage damage so I might get it repaired outside of a claim. To my non-mechanic eyes it’s something probably fixable by an independent but it’s definitely beyond my basic capabilities (I’d guess a Dealer repair to “as-new” would cost a small fortune). Just need to get it checked over and get a couple of quotes so would welcome any recommendations. Thanks.
  2. Happy Birthday K-Lye!

  3. Hi all.. so had an interesting experience this weekend. Transpires part of a route near where I've moved to has a ford. Naturally, there is a longer way around but given the nature of a 4*4 it's a bit daft not to explore the "off-road" capabilities of my RX350. Question is.. what is a safe water height to be attempting? When I passed through at the weekend, it was relatively low at about 30cm so had no problem.. but the watermarks on the indicators suggest it could get up to around 60 or 70 cm - I'm not so sure I'd want to attempt that! Anybody got some experience?
  4. Yea. Something's not right. The alarm also just went off for no reason whatsoever. Wonder if it's water ingest causing some sort of short. I'l book it in with the dealer. Thanks for the feedback.
  5. Hi all, just hoping to get some advice. I'll probably go to a Dealer to get this checked out but I'd like to get some other experience before I do so. Have recently bought a 2007 RX350 (40,000 miles) and it's got a fault with (I believe) the parking sensors. Essentially whenever I'm driving in rain, the sensors keep going off - the tone is consistent with something being too close to the vehicle but is evidently not. Furthermore, it's intermittent but regular (goes off every few seconds). What makes me confident it's the rain is of course, if doesn't happen when it's not raining but equally the issue is much much worse when driving at motorway speeds where there's a lot of spray. These are original fittings and not after market. Anyone had a similar experience?
  6. Also found through Google