Taylo3480

Members
  • Content count

    7
  • Joined

  • Last visited

Community Reputation

1 Neutral

About Taylo3480

  • Rank
    New Club Member

Contact Methods

  • First Name
    Chris

Profile Information

  • Gender
    Male
  • Lexus Model
    is200 se
  • Year of Lexus
    2000
  • UK/Ireland Location
    Devon
  • Interests
    Classic Cars
    Motorsport & Racing
    Car Restoration
    Car Modification
    Road Trips
    Entertainment
    Computers & Electronics
    Sports & Leisure
  1. New Is200 Parts

    Thanks Janey, Much appreciated! :)
  2. New Is200 Parts

    Hey all, Anyone know where I can get reasonably cheap parts for my is200 thats not ideally main dealer? My babys dropped two valves on banks 5 & 6 :megaangry:
  3. Cloudy Headlights :(

    I used G3 compound and an electric polisher. Then I laquered them and then flat and polished them again! Problem SORTED! ;-)
  4. Hi mate, thanks for the reply. Ive had the Traction Control tested and the car will not wheelspin with it on even though its flashing. Turn it off and it wheel spins very well indeed! ;-) The timing belts been done. Had that checked too. The timing lines marked are bang on. The diagnostic reading was done with a Snap-on machine (£15,000 worth) but it just didnt read anything. Im half tempted to take the stereo out to stop interference and get my mate to plug it into his system! If that doesn't pick anything up, nothing will! :-( I dont particularly want to take it to lexus to be honest. Appreciate the help with this though mate. Thanks again!
  5. Hi All, Right...got myself a 2000 Lexus is200 se (2000) A day after I got it, the Engine light came on and the TRC light started flashing. The car started idling low and rocking slightly, almost like it was missfiring. Instinct told me it was a coil pack so I tested them all (all fine) I even swapped all of my step fathers coil packs over as he also has is200 se but made no difference. I have done a fair few things to it and it just isn't making a difference. I clear the faults and the lights come on again :megaangry: The list of things I have done so far are as follows... 1. Full Service (inc: plugs, oil flush, all filters etc) 2. Took throttle body apart and cleaned it all, tightened up throttle cable as was sightly loose - Still slightly lumpy The only thing I can think it is now is the 'oil control valve' or 'camshaft oil control valve' (what ever you call it) Can anyone help as Im rapidly loosing the will to live now. Anyone having the same issue or can give any advice would be great. Diagnostic machine will not pick a fault up - Which doesn't help but mind you I have got a non-standard head-unit in and I have heard that they interfere with the diagnostic checking! HEEEELLLLLP???!
  6. Hi Mate, I had this issue. It turned out to be the brake light bulb in the parcel shelf that was out - Changed the bulb and it went out! Let me know how you get on. Taylo.
  7. Welcome to the Lexus forums Taylo3480 :)