Deet27

Members
  • Content count

    26
  • Joined

  • Last visited

Community Reputation

1 Neutral

About Deet27

  • Rank
    Member
  • Birthday 05/27/1974

Contact Methods

  • First Name
    Dietmar

Profile Information

  • Gender
    Male
  • Lexus Model
    Gs300
  • Year of Lexus
    2003
  • UK/Ireland Location
    Antrim
  1. Rockauto Parts

    Hi all need to replace both Front Lower Ball joints on my 03 Lexus GS300 and will be ordering from Rockauto which i have done plenty of times before(Denso Parts etc). I live in the UK and am unsure of which Make/Manufacture of suspension parts are good. Prices are for the pair delivered to the UK. Ultra-Power £32/$42 (Warehouse clearout) Daily Driver Mevotech £57/$75 Beck/Arnley £60/$79 Acdelco £74/$97 Premium MAS £56/$74 Moog £60/$79 Obviously I would like to buy the cheapest but dont know which ones to avoid, confused on why the Premiums are cheaper than the daily driver. Any advise would be appreciated.Many thanks
  2. GS300 Mk2 Wheels / Tyres

    Looking a bit of Feedback/Advice, Cracked one of my aftermarket alloys the other day and looking to get a set of OEM. My understanding is that the MK2 GS300 originally came with:- 225/55/r16 (16x7.5J) or 235/45/r17 (17x8J) with offset ET45 Mine are 245/45/R18 (18x8.5J) My preference would be to replace with Mk3 IS250 standard alloys as they were fitted originally with 225/45/R17 or 235/45/R17 (17x8J ET45) and should be a fairly straight swap I have managed to find a set of MK3 GS300 225/50/R17 and the wheel is 17x7.5J ET45? I have 3 concerns about these alloys that I would be really grateful for any advice. Has anyone ever fitted these? Do they look ok? My intention would be eventually to replace the tyres with 235/45/R17 and with the 7.5J would the tyre look proportionate? Many Thanks
  3. Changing the Transmission Oil Filter on my 03 GS300, The gearbox is starting to whine when in Drive and Reverse (sounds like a Power Steering Pump that is struggling like on full lock) gets quieter when gearbox oil warms up. Think the Filter might be restricted, nothing to loose by changing filter as car has done 185K Miles. (Drain and fills done at 136k,160k and 180k). Car shifts through gears fine. Went to Lexus and was quoted £95 for a filter and the parts guy was unable to find a gasket for the Pan, I've order a Filter and a Rubber Gasket from Rockauto £22 Delivered https://www.rockauto.com/en/moreinfo.php?pk=478553&cc=1416596&jsn=9 I was checking the service manual for Torque settings for the pan and noticed that Lexus uses a Tube of Red Silicone to seal the pan. Part no 08826-00090 (replaced by 00295-01281) @£32 Delivered from USA How important is it that I use the Toyota Sealant or will the rubber Gasket be adequate?
  4. Fuel Pump issue?

    From what i can recall no throttle, don't usually touch the throttle when starting. It was behaving it was like the immobiliser had kicked in. (I did not disconnect battery) Fuel filter has not been changed since I have had the car 136k to 183k Miles, on My to do list. When it started it spluttered for 10 secs or so then ran correctly, done 10k miles since and not had any issues or no starts since. The only thing that I have noticed is on the very rare occasion (5-6 times over 3 months ) when I have come to a full stop in drive the idle seem to be low like it was about to stall (450rpm ish) put it into neutral and revs pick up to 600 ish tap the throttle and it revs fine.
  5. Fuel Pump issue?

    Strange one this is, a few months ago I did an Engine Oil and Filter change as I have done many times before. Run Car to warm oil, Drain oil, Change Filter, refill with oil, run car and recheck/Top up The following morning started car it fired and died immediately, worried it was Timing Belt I checked it and was fine. Looked around the engine bay to see if i had dislodged a pipe or connector after doing the oil change and all seemed fine. Wanted to check the fuel pump but could not get the seat up. The engine was spinning at a good speed but not firing only tried for 5-10sec I was low on fuel as the light had only just come on but was sure I was not empty. Put two cans of petrol in the tank (10ltrs ) and after a few splutters fired and started. Come to the conclusion that I am an idiot for running out of fuel This morning same happened again, Started car, Fired once and died. Tried starting again just turning over not firing. Im not a person to keep cranking over the car when there is obviously something wrong. Used the wifes car as did not have the time to start mucking abut with the Lexus. About ¼ tank of fuel and I did a oil & Filter change yesterday. Got 5ltrs of fuel as the Fuel gauge might be wrong, again checked all around the engine and Timing Belt all good, Put the fuel in and after 5-10sec of cranking started to splutter and started. I find it odd that this has happened both after doing an oil change. My Gut feeling is that it might be the signs of the Fuel pump starting to go, does that seem likely signs/behaviour? Its difficult to know as when you switch the ignition on the Brake Booster will prime twice so you cannot hear the fuel pump priming Regards Dietmar
  6. Seen a quite a few old forum messages about using Transmission Oil Type i-v but the service manual states Power steering Fluid Dextron 2 or 3. Both the Forum messages and the service manual are over 10 years old. What type of Power Steering fluid should I use?
  7. Think your right, I recall reading myself that very expensive adding a Tow Bar to 2nd Gen GS300 for towing due to having to add an Transmission Cooler. Im not looking to Tow a big trailer or caravan just something like a tow bar Box (think it is only able to hold 50Kg) Just looking a little more storage http://www.handiworld.com/handioffers/handiholdall-handirack-handiduffel-orange2.html or https://www.amazon.co.uk/Thule-EasyBase-Carrier-Base-Bar-Mounted/dp/B001N3L47Q/ref=sr_1_2?ie=UTF8&qid=1464644619&sr=8-2&keywords=towbar+box
  8. Cheers for the response. Just contacted the seller and the part is not suitable for the 2nd Gen Gs300. They said that Lexus don't do/have discontinued roofbar for this model
  9. Hi all looking some help/info. I am looking to start camping and have realized that it wont all fit in the boot, So started to look at Roof Racks and Tow Bars but none seem to be available. There is a few forum posts from a number of years ago about Tow Bars but seem to be custom made and very expensive. Has anyone come across this and can point me in the right direction? Many Thanks Deet
  10. Wanted Front Caliper Carriers 2nd Gen GS300

    delete Please, Ordered from Rockauto
  11. Looking for both front Brake Caliper Carrier Brackets for my GS300 03 Regards Dietmar
  12. MOT Fail on Parking Brake efficiency

    Thanks for the reply, Got it sorted the other week just did not get the time to reply to my own post. It was the Handbrake cables had seized at the Brake back plate and the Casing had separated. It seems that the alloy had oxidized. A heads up to anyone looking to replace the handbrake cables, Order 91611-G0612 x4 as these bolts sheared off.
  13. Replaced my rear shoes last week as the Parking Brake has never been much use and as you can just put the car in Park was never concerned, But with the MOT due felt that it was about time to sort out. Car failed today on Parking Brake Efficiency 11% instead of 16% I thought that maybe I had adjusted it incorrectly and with me readjusting I got it checked out prior to re-booking MOT. It would have failed again. One thing that I have noticed is that the Parking Brake Pedal is very hard to push to the bottom but goes all the way (It is fine to start with, taking up the slack) and I have had to tighten the adjustment completely up to take up the slack.(seems odd thought that would of been the opposite with new shoes?) What I have done so far:- Replaced Shoes, Cleaning as I go and using Brake grease on the contact points Adjusted at the disc so will not move and back off adjustment 8 notches Adjusted Parking brake Pedal to take up slack Checked the cable equalizer(if that is the correct name, where the front cable joins the two rear cables) My gut feeling is that it is the rear brake cables sticking or maybe the brake drum run-out don't know until i check it tomorrow. Looking a bit of advise or Any insights into common problems with the Parking Brakes Regards Deet
  14. Cheers for the link, Was getting concerned that with doing reading after 15 mins was OK but after doing a reading of driving 1hr+ was showing overfilled. Car is used as Taxi and with doing mainly town driving wondered if oil was overheating/getting too hot. Car shifts good seems to be fine however have noticed lately that on very gental acceleration the rev counter seems to sit at 2k revs as it goes through gears barely dropping as each gear changes. Unsure if that is an early indication that something is wrong.
  15. Going to do a Drain and Fill on my Transmission as i think it has started to slip, I know there is some slippage on a auto box but have just got it in my head and prob due a Drain and Fill (come back to that later) I want to make sure that I have the correct level so that when I do the drain and fill I can just measure what comes out to make it easier to know how much to put back in. I am doing the readings with engine running after cycling through all gears (twice) pausing for 2 seconds at each point and outside temp is approx 5ºc each time. With engine Cold (Running for 2-3 Mins before reading) it Seems to barely on the dipstick, so that would mean that I need to top up? Engine upto Temp after driving for 15 mins, 5 miles in daytime traffic, it would read right between the hot marks, so Correct level does not need topped up? Engine upto temp after driving for 1hr, 30 miles daytime traffic, (idling for 3 mins before doing reading), would read over to hot mark by approx 1½cm, so level is to high and need to remove some trans oil? My understanding is that I should do a reading after 15-20 mins of normal driving, but am concerned that I am getting conflicting readings of Under-filled/Overfilled. Would appreciate any advise