V8Rumble

Members
  • Content count

    40
  • Joined

  • Last visited

Community Reputation

3 Neutral

About V8Rumble

  • Rank
    Member

Contact Methods

  • First Name
    TIM

Profile Information

  • Lexus Model
    LS 400
  • Year of Lexus
    1995
  • UK/Ireland Location
    Northamptonshire

Recent Profile Visitors

744 profile views
  1. Ls400 ecu

    I am in the process of locating an ecu for my car rather than mess with what is in the car albeit running badly. I have a mate who is a bit of a whiz with the electronics and will be doing the capacitor swap and then hopefully swap the reconditioned one with the faulty one. If all works out I will get him to recondition the other one as well (no good to you as my car is a 95) If you can wait a couple of weeks he may be able to do yours I will ask him when I see him. He is located in Rugby
  2. Engine ECU's

    Could anyone tell me whether the ecu's are different on different year cars? e.g. do I need an ecu for 94-97 for my 95 plate car or would a 91 fit? I think I read somewhere that some of them had an immobiliser incorporated
  3. Engine light on cannot get codes

    Changed the two primary O2 lambda sensors today Started fine, drove about a mile engine light on then off Did about ten miles light, on light off, stalling at junctions, idling fine No codes coming up again Have bought the capacitors and a good techy mate will be fitting them on the 10th Hopefully that will cure the problem as I am running out of ideas/options
  4. Engine light on cannot get codes

    Another update on this one Went on holiday for a week after driving to the airport in limp home mode Came back a week later and car drove home (60 miles) with no engine light and was great. Next morning after about fifteen seconds light on grrrrrrrr!! light went on and off at random and has done for about four days. The good thing was that it threw up two codes 21 and 28 This points to the primary pre cat CO2 sensors. Before I buy new ones is there any way to check them? Do they act erratically or just fail? As usual any help welcome.
  5. Engine light on cannot get codes

    The car bought up engine light when first started which I put down to silicone fumes curing. Reset ecu once it cooled and car drove great on a short journey. Left car for about four hours and tried driving. Engine light on after about a hundred feet and will not go out. Tried after car cooled but light still on. No codes coming up and cannot clear light by disconnecting battery. Getting annoying not knowing where to look for problem.
  6. Engine light on cannot get codes

    Just a quick update on this one. Hands up I didn't put the car in neutral when trying to lift codes (doh!) Once in neutral the codes 21 and 28 came up indicating O2 sensors. In a different post I asked about exhaust gaskets which I hope is throwing up the codes and limp home. Going to fit the gaskets I got from main dealer and see what happens, but I have noticed part of both front pipe flanges have corroded a bit so have bought some fire proof silicone good up to 1200 degrees C. Fingers crossed will let you know.
  7. Engine light on cannot get codes

    Thanks for the heads up on that Steve will check on my day off Thursday. Malc the car went into limp home mode after about a mile this morning on the way to work (about three and a half miles). No engine lights on the way home will see what happens tomorrow lol.
  8. Engine light on cannot get codes

    Hi again The saga continues. Went to the car this morning and it started no problem, no engine light but did not idle. Came to the first junction and it idled spot on. Drove perfect with no light all the way to work. Came home and ran a treat with no engine light Hmmmmmmmm?
  9. Engine light on cannot get codes

    Thanks again for the pointers I will make the checks tomorrow after work before it gets dark. It is a 95 but has the OBD1 port so probably one of the first ones distributed. I have taken codes with the link before. Forgot to mention the exhaust is blowing which may/may not have a bearing. The car will not even tick over now, never ending lol but it had been standing before I bought it. Just had a top half respray so no turning back now lol. Could you give me a pointer as to where the cam sensor is please
  10. Engine light on cannot get codes

    Also the light does not go away if I disconnect the battery
  11. Hi again Changed distributor caps , rotor arms and leads and car ran okay. Engine came on after about twenty miles and car is in limp mode Tried to get codes by linking TE1 and E1 ports but nothing shows up the engine light stays solid Any ideas on this one
  12. Exhaust gasket

    Cheers for the info
  13. Exhaust gasket

    Hi Can anyone let me know of a supplier in the UK of exhaust gaskets for my LS400. I am after the one that joins the cat to the main system I assume it is a ring. Can only find U.S. suppliers but they flag up as U.S. fit only Any links welcome
  14. Engine Revving Problem

    Check this out https://www.clublexus.com/forums/ls-1st-and-2nd-gen-1990-2000/656360-all-my-crazy-lexus-issues-solved-ecu-leaking-capacitor.html
  15. I bought my fluid and filter from America when I previously had an LS400 Amazingly with shipping and import charges it was cheaper than buying in this country. Go figure about rip off Britain! I have a filter kit for a MK4 for sale at mates rates if anyone needs it