AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


  • Similar Content

    • By djgrubber
      Hi All,
      I have an orange indicator light constantly on. It is the auto levelling warning light. I guess it tells me that there is something wrong with the autolevelling. My car has recently passed an MOT and I know that the lights are set on the correct level. 
      I assume that one of the height sensors (perhaps the one at the back of the car) is not working properly. I was wondering what is the best way to identify which sensor failed? I don't feel like changing all sensors or lamps without knowing what went wrong.
      If I connect the car to the TechStream or some OBD2 scanner would it tell me exactly which sensor failed?
      Thank you for a reply in advance.
       
    • By Nigel_S
      I wonder if anyone can shed any light on an issue I am having with my 2005 RX300... please?
      I noticed a little while ago that, occasionally, under normal (not harsh) braking at low speed, or under normal (not harsh) acceleration from standstill, either the ABS or Traction Control would kick in.
      The ABS "effect" seemed to be coming from the off-side front and so at a recent service I asked the garage to check the ABS rings and examine whatever they could get into, on all four corners. This they did and reported that everything appeared as it should be.
      More recently, I was advised that the issue could be a dirty ABS/Speed Sensor (maybe a small piece of road dirt or debris had become lodged etc...) and that if it could be removed it might be cleaned, however, they also had a tendancy to break if not having been removed before and so the best course of action would be to buy a new one and change it completely. This I did and the work was completed just a couple of hours ago ...and I can report that it most definitely appears that the offside front was the culprit because now, pretty much every time I pull away, the Traction Control kicks in!
      The only thing that has been changed was the sensor (Part Number checked before purchase and fitment), so I can only assume with a new sensor in place the issue has become more apparent.
      So, can anyone offer me any advice as to what to do next?
      Is it worth going ahead and changing the sensor ring, just in case, or has anyone else experienced this and has a "fix" that works?
      Any help/advice/assitance would be greatly appreciated.
      Many thanks.
      Nige.
    • By PCM
      that... the SatNav on my RX has a compass.
      Yes, I know it sounds obvious, but I just never realised it before!
       
    • By MurrayN
      Hello,
      As the title suggests I'm new to owning a Lexus and almost by default. I've owned SUV's before (Honda) and intended reverting to younger days and a convertible, but once I tested a few, realised that comfort and a loftier driving position were for me! 
      I came across a 2005 RX300 ES L, with 48k on the clock and serviced annually. Although the previous owner (2nd from new) had used this as a young children carrier, I saw past the sticky upholstery and badly stained carpets. (It didn't smell too good either) Anyway a smooth test drive and now it's mine for a very reasonable price.
      I'm amazed by smoothness and the kit on these, actually more that my previous car, which was a 2013. It'll take some retraining and I suspect some daft questions to you all, before I get to grips with it all.
      Just a couple for now. It only came with one key, (their little boy buried one on the beach!) and although working the casing is held together with tape. The dealer wants £150 for a new key and coding it. Any advice? And SatNat - it'll need updating. Anything I should about those on eBay? 
      Thanks Murray 
    • By Nickyt211
      Hello
      i brought my rx300 a few weeks ago now as helped by you all in my previous post. I'm now looking into the adjustable coilovers it has fitted. I'm sure that at the minute it is set too low. I'm going to be taking it to a garage this week so I wanted to ask, Does anyone know what the standard ride height should be for a 2004 rx300? So that I can tell them. The other question is is it something I could do myself or is a professional advised.
      thanks guys