• Join Gold & Save!
      Join Gold & Save!
    • Get Your Club Gear
      Get Your Club Gear
    • Massive Choice on Lexus Parts
      Massive Choice on Lexus Parts
    • 1000's of Lexus For Sale
      1000's of Lexus For Sale
    • Save Up To 15% On Your Lexus Insurance!
      Save Up To 15% On Your Lexus Insurance!


AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Mars

IS200 Sat Nav

9 posts in this topic

So I turned my Sat Nav unit on this morning and it was a bit slow to open/respond but it did open and I was met with a message "Unable to read data. Check map dvd is correct."

Any ideas as to what is causing this?

Share this post


Link to post
Share on other sites
 

Had it been working okay previously?

Share this post


Link to post
Share on other sites

Perfectly for the past 14 years. Changed the interior during the summer and everything electrical was working fine thereafter. The one thing I have noticed is the there is condensation on the insides of the front and rear screens.

Share this post


Link to post
Share on other sites

you might have to take the disc out and give it a clean and see what happens

Share this post


Link to post
Share on other sites

Will do. I will have a go tomorrow. 

IMG_0844.JPG

Share this post


Link to post
Share on other sites

19 hours ago, scudney said:

you might have to take the disc out and give it a clean and see what happens

Ok so the DVD Disc is out. Looks fine and the system is detecting that there is no DVD in the reader. Going to clean it up and see what happens.

Share this post


Link to post
Share on other sites

All working now. Thanks Scudney. 

IMG_0850.JPG

Share this post


Link to post
Share on other sites

glad to be of assistance,giving it a clean usually works if there's nothing wrong with it,haven't had any problems with mine 😊

Share this post


Link to post
Share on other sites

2 hours ago, scudney said:

glad to be of assistance,giving it a clean usually works if there's nothing wrong with it,haven't had any problems with mine 😊

Personally I think it may have something to do with the weather.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.