SLACKBLADDER

2003 rx 300 cd player

Recommended Posts

Here's another problem I had a cd stuck and it wouldn't eject anyway just by perseverance so now it won't load . I tried disconnecting the battery  and won't load have any of you guys had this problem 

Share this post


Link to post
Share on other sites
 

Never experienced this myself Les so can't help really, but does it show any error message? Mine once showed 'ERROR 4' but then corrected itself the day after  :wacko:

Oh, and you may get more responses by posting in the RX300 forum - not sure if the same CD player was used across the range.

Share this post


Link to post
Share on other sites

But I did do the hold info button and turn lights on three times not a lot of help that was 

Share this post


Link to post
Share on other sites

Took the cd player out shook it violently put it back in and would you believe it works loads ejects brilliant 

  • Like 1

Share this post


Link to post
Share on other sites

Haha, really... that's brilliant!

Must have been a very satisfying way to fix a problem :thumbup1:

I guess the mechanism was jammed up somewhere...

Share this post


Link to post
Share on other sites

Yeah definitely enjoyed that strange thing is that the locating pins holding the gearshift surround in place one was broken and the four bolts holding the radio cd stacker unit weren't there    tells me the last owner had previous problems. So in future  if in doubt  shake it shake it real good 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now