RX300 MK2 SatNav issue

Recommended Posts

Hi all

Please can someone help with any ideas.

I've purchased a new version disc and tried to upload it and getting an error of "Cannot read data" (bought of eBay so possible copy).

I tried to install the previous one I have 2006 disc which never give me a problem and has worked perfect since install around 7 years ago. This is now saying "No disc/Cannot read data"

If the eBay disc tried to load new firmware would it stop my old 2006 disc from working ? Any ideas what would be the problem . Would getting a Disc from Lexus sort this out ?

Thanks in advance


Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.