Recommended Posts

Hi all, I got my 2013 is300h F sport two months ago and I'm also having issues with the audio system. Its been on and off for past 5-6 weeks now I have no sound at all from any sourse including voice command on steering  wheel. My car is currently in my local Lexus dealer having this looked at, they are thinking its the amplifier at fault and should be replacing it tomorrow, luckily  i bought the car with a Lexus warranty so this should be covered. Will update on this when i get car back hopefully tomorrow.

Share this post


Link to post
Share on other sites
 

Best of luck with this. I seem to recall a long saga a while back when someone else had issues with the amplifier/audio head unit. 

These are horrendously expensive and, IIRC, the dealership tried 'borrowing' a unit from another car in stock. I'd imagine a new one would take a while to become available?

Share this post


Link to post
Share on other sites

Audio problem is finally sorted, had to have the amplifier replaced and all seems ok now, luckily this was done under warranty as would of cost me best part of £1000

Share this post


Link to post
Share on other sites

Glad it is all sorted out. I'd like to think that if you didn't have a warranty that you could get it fixed for less, or found a vehicle being scrapped with a good amp.

Share this post


Link to post
Share on other sites

Blimey  £1000 for an amp! I spent less than that in my previous car and it's sound trounced the ML I have.

Glad you got it finally sorted. Now enjoy. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now