Recommended Posts

Just bought (less than 48 hours ago!) New NX300h Luxury  2018 which comes with Premium Navigation.  Still finding my way around the nav system, I previously had a CT200h with Premium Nav which is very different.

Some questions before I get back to Lexus.

1.  I don't get any bleep warnings approaching speed cameras - can't see how to enable.  The Camera Icons are visible on the map.

2.  Is it possible to show speed limits on the map?  On one of the settings its greyed out.  Possibly because the car reads the real road signs and displays them on the centre console anyway, perhaps you can't have both?

3.  Settings for the vehicle are greyed out - can't see how to enable.

So far I love the car!

Thanks for reading this.

Share this post


Link to post
Share on other sites
 

2 - should be possible. Road sign assist and the Nav are two independent systems.

3 - some settings will be greyed out unless the vehicle is in it's 'Ready' state with the transmission in park.

Share this post


Link to post
Share on other sites

Thanks Colin

Putting it in Park and the system in Ready now allows access to the Vehicle settings menu.

Speed limits for the maps still greyed out.

Will listen for speed camera bleeps tomorrow.

 

 

Share this post


Link to post
Share on other sites

It does bleep when approaching a speed cam just not very loudly. 

 

As you I love the vehicle to drive but hate the sat nav, seems to be not as accurate as some I have had in the past. On some drives whether destination is set or not I glance at the screen and sometimes it shows me as not being on a road at all. I’m not sure how up to date the map data is either. 

Share this post


Link to post
Share on other sites

I never said I hate the sat nav, just that it is very different to the version on my CT200h, and I have already got used to it!

My preference is to always show the map orientation North.  Personally don't like navigation on 3D maps.

Just driven 250 miles on B, A roads and M'ways and found the accurately absolutely fine.

Still not heard speed cam warning when expected even where I have with the CT200h.

Share this post


Link to post
Share on other sites

3 hours ago, Centre100 said:

I never said I hate the sat nav, just that it is very different to the version on my CT200h, and I have already got used to it!

My preference is to always show the map orientation North.  Personally don't like navigation on 3D maps.

Just driven 250 miles on B, A roads and M'ways and found the accurately absolutely fine.

Still not heard speed cam warning when expected even where I have with the CT200h.

Ive found some don't beep and it varies between my RX and IS so not really sure about the algorithm behind the bongs.

The speed limit on the Nav was present on the older nav systems i.e. 3RX, 1st facelifted CT 2014 onwards (not sure about before that) and pre-facelift 3IS/RC and the pre-facelift NX.

Its no longer the case and there is no longer speed limit signs on the nav with the newer nav systems

Share this post


Link to post
Share on other sites
1 hour ago, rayaans said:

Ive found some don't beep and it varies between my RX and IS so not really sure about the algorithm behind the bongs.

The speed limit on the Nav was present on the older nav systems i.e. 3RX, 1st facelifted CT 2014 onwards (not sure about before that) and pre-facelift 3IS/RC and the pre-facelift NX.

Its no longer the case and there is no longer speed limit signs on the nav with the newer nav systems

Thanks for that

Just been through a series of 5 cameras near here which the older CT200h bleeped at, but not his one. The map does show the cameras.

The  Road sign assist  works which ought be be sufficient.

 

Share this post


Link to post
Share on other sites

Have you been through all the options under Menu > Setup > Navigation > Map, there are two or three pages of options?

Share this post


Link to post
Share on other sites

I think the camera alert sound is possibly linked to the Sat Nav voice volume. Raise that volume to see if it makes a difference.

Share this post


Link to post
Share on other sites
56 minutes ago, ColinBarber said:

Have you been through all the options under Menu > Setup > Navigation > Map, there are two or three pages of options?

Yes I have. That's where 'Speed Limits'............Show on map is greyed out.  Nothing there about camera warnings either.

 

 

Share this post


Link to post
Share on other sites

I get the camera beeps on my 2018 model NX f-sport but as Rayaans has stated you dont get the speed limit displayed on the latest sat nav because its displayed on the speedo console.

Share this post


Link to post
Share on other sites

Definitely getting the beeps on my 2018 MY luxury so it should work. As stated they're not particularly loud though.

Share this post


Link to post
Share on other sites

16 hours ago, ColinBarber said:

Have you been through all the options under Menu > Setup > Navigation > Map, there are two or three pages of options?

Did but has nothing there. 

Might try it again. Would expect it to be the same on the GS-F as the 4RX runs the same system?

Share this post


Link to post
Share on other sites

Yep, I went through my settings. Nothing for safety camera alerts - mine definitely beeps and volume seems linked to Sat Nav voice volume.

My GS also doesn't provide the ability for speed limits to be displayed. Looks like Lexus has removed this because the vehicle has road sign assist however that isn't the case with Toyota, my wife's Prius has both. My system is a 2015 so the 2017 system in the latest NX may be different.

Share this post


Link to post
Share on other sites
On 4/23/2018 at 2:02 PM, ColinBarber said:

Yep, I went through my settings. Nothing for safety camera alerts - mine definitely beeps and volume seems linked to Sat Nav voice volume.

My GS also doesn't provide the ability for speed limits to be displayed. Looks like Lexus has removed this because the vehicle has road sign assist however that isn't the case with Toyota, my wife's Prius has both. My system is a 2015 so the 2017 system in the latest NX may be different.

Set my Nav Voice to maximum - not a murmur from the Camera Alerts.  My dealer is investigating.  Apparently there have been some software updates for this model/year.  Hope they can sort it soon.

Share this post


Link to post
Share on other sites

Contacted another Lexus dealer, he reports the latest NX300h do not have speed camera sound alerts.  Possibly due to a European directive.

Share this post


Link to post
Share on other sites

Then why does mine which is the latest model f-sport. Unless its not on the lower models.

Share this post


Link to post
Share on other sites
1 hour ago, Eggie said:

Then why does mine which is the latest model f-sport. Unless its not on the lower models.

Good point! Dunno!

Currently one of life's mysteries.

Share this post


Link to post
Share on other sites

We have had IS owners complaining they cannot disable the camera alert beeps for years, now NX owners are complaining they cannot enable the beeps.

Not sure why Lexus can't just give us a simple toggle option in the settings :wallbash:

Share this post


Link to post
Share on other sites

Its not loud or intrusive. Also a speed camera symbol appears bottom right of screen

Share this post


Link to post
Share on other sites

I have 2018 NX Luxury two months in and loving my first NX. Found Sat Nav bit clunky initially but now used to it and find it really accurate - I use it daily to check trafic on commute and it’s actually more accurate the Audi/VW/ Mercedes I have had. I can confirm there is definitely no speed camera sound on mine having listened and explored thoroughly


Sent from my Iphone using Tapatalk

Share this post


Link to post
Share on other sites

Looking at the responses it seems the NX300h F Sport does have the warning bleeps and the Luxury perhaps not.

I understand there is a software update due in about 10 days which is supposed to fix an issue with the Sat Nav locking up on the latest NX maybe it'll fix other issues too?

 

Share this post


Link to post
Share on other sites
On 4/28/2018 at 6:57 PM, Centre100 said:

Looking at the responses it seems the NX300h F Sport does have the warning bleeps and the Luxury perhaps not.

I understand there is a software update due in about 10 days which is supposed to fix an issue with the Sat Nav locking up on the latest NX maybe it'll fix other issues too?

 

Now got the double 'gong' when approaching the map's known speed/safety cameras.  The sound was set to off, I assume default.  Not an obvious setting though....in settings, select General, Selection Sound.

Cameras displayed from the Internet don't sound (like the newer ones on the M3 'Smart Motorway'). Distance count down to the camera also works , also shown from the Internet are roundabout symbols with count down.

  • Like 1

Share this post


Link to post
Share on other sites

In my NX, which is less than 3 weeks old, road sign assist has displayed (in the centre console and on the HUD) the speed limit to be 110. On another occasion it showed 10. Fortunately I knew the speed limit on both occasions was 30mph so ignored the info. Usually though when it does show a limit it is the correct limit, but has anyone else had a similar experience?

Sent from my SM-G920F using Tapatalk

Share this post


Link to post
Share on other sites
On 05/05/2018 at 7:07 PM, Centre100 said:

Now got the double 'gong' when approaching the map's known speed/safety cameras.  The sound was set to off, I assume default.  Not an obvious setting though....in settings, select General, Selection Sound.

As my LC has similar SatNav to the latest NX, I have tried the Settings/General/Selection tone setting toggle. I can confirm that it switches on/off the camera warning tone as per above.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now