fasteye

Aristo V300 Oil explosion

Recommended Posts

My 98 Aristo V300 decided to empty the contents of the sump on the road yesterday. I haven't had a chance to take apart and find the source and when the AA came out they said basically everything is so covered in oil dripping from everywhere it's hard to tell, they just loaded it up and brought it back.
Engine was still running with no noises prior to me turning the engine off and not overheating. Any thoughts on the first places to look or anyone aware of common failure points which make the 2JZ-GTE engine let go like this? It was due an oil change but it wasn't the way I had in mind!

Share this post


Link to post
Share on other sites
 

Not a common issue. If the engine was fine then it points towards something external such as turbo or oil cooler. It could possibly be a leak at the front of the engine which drips onto the belt and thrown everywhere.

Share this post


Link to post
Share on other sites

This was a major spill like with oil pouring out almost as fast as if if the sump plug is removed. Left a trail of oil on the road and the undertray and under the car is covered with dripping oil. I'm wondering if it could be the oil seal on the oil pump gone.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.