DaKa

Malfunction Indicator

Recommended Posts

Last night the malfunction indicator lit up on the dash of my 2001 LS430 while wafting around at about 30 mph..

I guess that I will need some plugin computer check for the error code, perhaps it could turn off again (he says hopefully!).

Would anyone know what the most likely cause for this may be? The car is certainly in need of a service but otherwise its running smoothly and nothing noticeable sound or performance wise?

Thxs

Share this post


Link to post
Share on other sites
 

pure speculation but possibly an air/fuel ratio (oxygen sensor) problem as they commonly fail on older vehicles and don't always affect performance.

Share this post


Link to post
Share on other sites

I know nothing ...........  but prior thoughts have been that the fuel filler cap might need taking off and putting back on again ......  weird I know but that's said on here before !

Malc

Share this post


Link to post
Share on other sites

It turns out that I've been lucky, as it seems to have been only that the Battery wasn't charging properly, and it was just the Battery, not the alternator.

New Battery fitted (the old Battery was probably older than I thought circa 7 years) and everything great again.

My daughters boyfriend had persuaded me last night to by the new i30N Hyundai (he's collecting is next week) so it will just have to wait now until something else goes wrong on my Lexus - it could be a while then! 

Do I need to touch wood or cross fingers?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now