Recommended Posts

I haven't heard the bubbling for a while however fans still don't spin.. gonna change the rad..

601f2d4f074b258ab69f8a0bd897fafa.jpg&key=7374c55ebcae31e541881fd9edebcd2e3250db34ec46bd2a4ffb0ec91b3eba23

What's the extra 2 hoses at the bottom? Did I buy the wrong part?

Sent from my CLT-L09 using Tapatalk




The two extra hoses for the auto transmission fluid cooler.


Sent from my Iphone using Tapatalk Pro
  • Like 1

Share this post


Link to post
Share on other sites

Attempting to clear the block as the fans don't come on themselves

e9f05035898d9a5b62a6cffbd78d3455.jpg

Sent from my CLT-L09 using Tapatalk

Share this post


Link to post
Share on other sites

Drained the coolant from the radiator drain thing... Front of car was already up... refilled the coolant... Temp and power on full blast and NOTHING

Top hose gets hot, bottom hose stays cold, no bubbles in the radiator fill cap

Whats my options peopleeeeee 😢 I'm stuck... I've gone through all radiator threads and can't find a solution.

Changed thermostat, waterpump, temperature switch sensor and radiator..... KMT

In the wise words of Lucie from Love Island. "I just don't know what to do 😥". 

advice????

Share this post


Link to post
Share on other sites

Can we recap on what is happening, or not happening?

The temp gauge goes to half way, and no higher?

Have you let the car run for long enough for thermostat to open (to get flow through the radiator).

If it gets too hot (temp gauge) and the rad bottom hose is still cold, did you put the thermostat in the right way up (with the airlock toggle at the top), and right way round (if it’s the wrong way round, it won’t open)?

If it’s not overheating, and ambient temperature is not letting it get too hot, the fans won’t come on, so maybe there is nothing wrong.

Do you get heat in the cabin?




Sent from my Iphone using Tapatalk Pro

Share this post


Link to post
Share on other sites



Can we recap on what is happening, or not happening?

The temp gauge goes to half way, and no higher?

Have you let the car run for long enough for thermostat to open (to get flow through the radiator).

If it gets too hot (temp gauge) and the rad bottom hose is still cold, did you put the thermostat in the right way up (with the airlock toggle at the top), and right way round (if it’s the wrong way round, it won’t open)?

If it’s not overheating, and ambient temperature is not letting it get too hot, the fans won’t come on, so maybe there is nothing wrong.

Do you get heat in the cabin?




Sent from my iPhone using Tapatalk Pro


Temperature gauge goes halfway and no higher.

I've left it running for a while, engine gets really hot, top hose gets hot, bottom stays cool

I can't confirm on the thermostat, I took out the old one and replaced with the new one in the same orientation but it may have not been working before either

The outer fans work but the middle ones do not.

Sent from my CLT-L09 using Tapatalk

Share this post


Link to post
Share on other sites

Lol, so got my OBD2 £5 eBay connector thing so I could see how the coolant temp was behaving

 

Coolant how up to 90 before game kick in.. normal? I'm so excited, I think I was over cautious of the engine literally getting so hot you could feel the heat when you step out the car.

 

And ERM, The reason for the middle fans not working was because I had the directional setting set to clear the window.

 

My girl moved it to point at your face after she asked "have you tried this"

 

She's never gonna live this down

 

On another note, 70 miles from £30 fuel.. is that normal? Also, 0 -60 in 13.5 seconds... Faaaaaking hell it's a tad slow. Very comfy tho

 

Sent from my CLT-L09 using Tapatalk

 

 

 

 

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Club Hybrid Poll

  • 65 Hybrid Reliability

    1. 1. If you were to consider buying a Hybrid model over 5 years old, would you be worried about the reliability of the Hybrid system?


      • Not really as Hybrid systems are always reliable
      • Not if it had a Manufacturers Warranty on the Hybrid system
      • I would not buy a Hybrid model over 5 years old