Recommended Posts

Hello everyone,

Only just joined.

We've got an 2002 model. Bronze, cream leather. We love it. We have made a couple of alterations so that we can keep some of the original parts safe and sound in the garage. ( New alloys and exhaust)

There are a couple of issues that I wandered if anyone knew how to solve. The window switches only work on down ( we have to use the roof switch to close them). Do we need to replace the switches or can they be repaired. If we need to replace them are there a cheap source of supply.( we had a crazy price from Lexus).

Also there's a wind hiss where the drivers pillar meets the roof when it's closed. Does anyone have any experience how to solve these issues?

 

 

  • Like 1

Share this post


Link to post
Share on other sites
 

Hi Ben, welcome to the fold, firstly prob not a good idea to have your email as a user name ( never know what it may get used for!).

As for your window problem, I am not au fait with the SC430, but have you done a window 're-set' as per the owners manual?

Paul m.

  • Like 1

Share this post


Link to post
Share on other sites

Hi Ben. 

My previous experience with convertibles (MX5, BMW Z3 and Mercedes E250 cabriolet,) suggests that coating all rubber seals with gummi phledge may be the first step in softening the seals causing them to swell and fit better. 

Regarding the windows then I would certainly explore resetting them before anything else. 

  • Like 1

Share this post


Link to post
Share on other sites

Hi Ben, welcome to the club - we need photos of your beast  :thumbsup:

  • Like 1

Share this post


Link to post
Share on other sites

Hi Ben, welcome. 

The US owners have addressed the drivers 'A' pillar wind noise issue a few times. It can be the angle of the glass causing it to not seal properly or a split in the seal or the seal not seated correctly. There are a few threads that cover it on clublexus. Search with 'Lexus SC430 wind noise' and you should find the threads. 

I've had an occasional door mirror wind noise issue at high (ish) speed if it's very slightly out of position but nothing that a little extra audio volume couldn't fix.

From the passenger door try lowering the window to half way and then put it back up and hold the switch in the up position for about 5 secs. If that works, do the same to the drivers window and that should be it reset. If it doesn't reset it, you may need to take the door panels off to investigate further with a multimeter. If you need to do that we can help with instructions and pictures. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.