Recommended Posts

Hi all - this maybe an obvious question so apologies up front, but my RX300 which had power this morning is now not doing a thing. When I put key in and turn nothing happens not even a vague light on the dash. Is this just the Battery or something else?

Thank you!

Share this post


Link to post
Share on other sites
32 minutes ago, Michael Hurn said:

Hi all - this maybe an obvious question so apologies up front, but my RX300 which had power this morning is now not doing a thing. When I put key in and turn nothing happens not even a vague light on the dash. Is this just the battery or something else?

Thank you!

Have you got a simple multimeter so you can test the Battery? Always a good tool to have, especially as they can be bought for as little as £8.  It seems very unusual for one to loose total power so quickly.

Share this post


Link to post
Share on other sites

As Phil says, a multimeter would be a great asset to have for things like this.

Take off and clean both Battery clamps, also take off and clean both ends of the Battery to body earth strap and the engine to body earth strap (and also the other end of the Battery +ve cable) and make sure to tighten them properly when replacing.

If that doesn't sort it, you really need a multimeter.

  • Like 1

Share this post


Link to post
Share on other sites

Happened to me once...

Was a loose Battery!

  • Like 2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Club Hybrid Poll

  • 74 Hybrid Reliability

    1. 1. If you were to consider buying a Hybrid model over 5 years old, would you be worried about the reliability of the Hybrid system?


      • Not really as Hybrid systems are always reliable
      • Not if it had a Manufacturers Warranty on the Hybrid system
      • I would not buy a Hybrid model over 5 years old