Recommended Posts

Hi everyone. A few days ago my 1998 LS400 started having an erratic idle. It bounces from a virtual stall back up to 1200 or so then repeats. This happens in gear and in park. It's also got a noticeable misfire. 

I've been meaning to get my ECU done for a while, is this likely to be the cause?

I have no lights on the dash. No EML. I've had a few other symptoms that seem to relate to ECU also previously. Bad shifts, random limp mode and vac light on once. Poor low end power and no communication from ECU on obd port. 

All advice is appreciated. Feels like every time I fix one thing another pops up at the moment. 

Share this post


Link to post
Share on other sites
 

The bad capacitor issue of LS400 ECUs is very well documented and has a range of dozens of possible symptoms, so you really need to bite the bullet and get that done first to give you a stable baseline to work from.

Share this post


Link to post
Share on other sites

 

 

Check this out. 

https://www.clublexus.com/forums/ls-1st-and-2nd-gen-1990-2000/656360-all-my-crazy-lexus-issues-solved-ecu-leaking-capacitor.html

 

 

 

Share this post


Link to post
Share on other sites

Thanks everyone. I'll get the ECU out and have that done first

Share this post


Link to post
Share on other sites

Matthew,

Cannot recall your previous work on car from your other posts, but when I had ECU problems in Mk3, it never behaved like yours, mainly it would run at 600 to stall, never ran up to 1200.  However on Mk4 I now have I had something similar and it was throttle body that needed a good clean.  Also had new plugs fitted at last MOT and that has cured the odd gear shifts I got.   Never had limp mode (only had that in an Omega - which was auto-box playing up), or vac light.

Admittedly my Mk4 is 2 years younger, but the ECU is not showing any of odd problems, so if it is leaking it has not (to date) gone AWOL like the one in my Mk3 was doing. 

I know what you mean about curing one problem seems to highlight other niggles (and sometimes bigger issues), so best of luck

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.