Recommended Posts

Hi guys hate my first post being a problem one but own a 1999 altezza and today on way home it's developed an issue. Was perfect this morning but now the fuel gauge is Showing empty, the temp gauge doesn't work, the outside temp is Show ing E and the auto gear indicator is dead. Any idea where to start looking?

Share this post


Link to post
Share on other sites

Sounds electrical so as a starting point I'd check for tightness of Battery clamps. Even if tight, take them off and clean both the clamps and the Battery terminals.

Next, disconnect, clean and reconnect the other ends of the Battery leads, and both ends of the body earth strap and engine earth strap.

Hopefully that'll sort it but if not, see if any OBD2 codes are present and let us know what they are.

Share this post


Link to post
Share on other sites

Has the windscreen been replaced?

This used to happen on the is200 and was water ingress into the fusebox (think it was passenger side but could be wrong). Check both sides and feel around the back. Re-seat the connectors to the fusebox.

Share this post


Link to post
Share on other sites

No but has happened after this bad weather. Will check fuse box 

Share this post


Link to post
Share on other sites
12 hours ago, Geoffers said:

Has the windscreen been replaced?

This used to happen on the is200 and was water ingress into the fusebox (think it was passenger side but could be wrong). Check both sides and feel around the back. Re-seat the connectors to the fusebox.

Good call that man. Unplugged connectors clean up with wd40 and all is well. Car gas original screen but did feel damp behind the fuse box 

  • Like 2

Share this post


Link to post
Share on other sites

Happy days 🙂

Keep your eye on trying to find the source of the dampness though. It's usually the seal on the windscreen. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Club Hybrid Poll

  • 68 Hybrid Reliability

    1. 1. If you were to consider buying a Hybrid model over 5 years old, would you be worried about the reliability of the Hybrid system?


      • Not really as Hybrid systems are always reliable
      • Not if it had a Manufacturers Warranty on the Hybrid system
      • I would not buy a Hybrid model over 5 years old