Recommended Posts

Hi, I have a faulty horn on my Lexus RX400h 2005 - I have checked the fuse and all appears OK, it has been suggested that the Horn Relay could be at fault but I don't seem to be able to locate it. Various websites offer no help either - does somebody know where the little blighter might be please.

Share this post


Link to post
Share on other sites

This is what the workshop manual says:

837115067_2019-07-14(1).thumb.png.c28979be2d816ec6078d1466e3f620da.png2019-07-14.thumb.png.e1e8e828d70f3ec156800f0a77b45458.png


rx400horn.thumb.png.664b6a9b6d4dae8a946e09634cb85821.png

Share this post


Link to post
Share on other sites

Thanks Herbie, I managed to find the relay set, the relay shown in the manual diagram says on the plastic cover 'RDI Fan No.2' - I wonder if this is a dual function relay? I do have a couple of photo's I took - I'll see if I can upload them to this forum - thanks for your help.

Share this post


Link to post
Share on other sites

When mine stopped working it was a loose earth wire I believe ... 

  • Like 1

Share this post


Link to post
Share on other sites

Hi again - does anybody  know if the diagram posted by Herbie above points to the relay image (r/h photo) which is labelled on the underside of the plastic cover as RDI FAN No2. Is this a multi function relay that will also operate my Horn.

Share this post


Link to post
Share on other sites

I honestly don't know, but pull it and test it anyway, see what results you get.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.