Niklas Kjellström

IS200 Unique central locking problem, only works one way

Recommended Posts

Hello!

 

I really need some help with my is200! Ive had it for a couple of years now, bought it with a defective central locking system and have yet to solve the problem with it. 

Ive googled around for hours and hours and read countless forum threads, most from this site, which made me finally coming here asking for help!

I will try to explain everything as good as I can:

The car is a -03 is200 sportcross. As far as locking goes, everything works just like it should; all doors and the boot locks, and the alarm gets activated. If I'm in the car and use the button on the arm rest, all doors lock as well, as they should. Perfect.

However, when unlocking the car, they key fob ONLY unlocks the boot. It also deactivates the alarm system. But it does NOT unlock the doors, even though there is a clicking noise coming from the doors! I know this, because I listen for this clicking noise before i proceed to open the drivers door with the actual key, since otherwise the alarm will go off.

I have obviously tried both remotes and switched batteries in them. Unlocking from inside the car with the button on the door does absolutely nothing, its like that side of the button is dead, there's no clicking from the doors even.

So, my procedure to get in the car is: pressing the unlock button on the remote and listening for the clicking sound, opening the drivers door with the actual key, then getting in and opening the other doors from inside the car by leaning across to reach.

I have checked the fuses for DOME and MPX-B and they are OK. It does not seem to be a problem neither with the remote, or a fuse, since everything is responding when pressing the unlock button..

 

To make things a little more complicated, I have some sort of "double lock" feature on my IS. When trying to unlock the car with the remote, it succesfully unlocks the double lock on the doors, this is quite audible. If i keep pressing it, I only get the more faint clicking noise that I described earlier. 

 

I hope I haven't made this all too confusing, my first language isn't english so don't hesitate to point out if something is unclear! I would be so thankful if any of you guys may know the answer to this!!

Lots of thanks in advance!

Greeting from Sweden

Share this post


Link to post
Share on other sites

Check the wiring on drivers door where the wires go from the pillar to the door 

Share this post


Link to post
Share on other sites
6 hours ago, clifton 94 said:

Check the wiring on drivers door where the wires go from the pillar to the door 

Should I check inside the door, or inside the cabin? The cables from the door seem to enter just above the fusebox by the pedals! Anything specific you thought of?

 

Thank you!

Share this post


Link to post
Share on other sites

There is a rubber boot that goes from door to pillar sometimes the wires can break in that area 

IMG_1671.JPG

Share this post


Link to post
Share on other sites
3 minutes ago, clifton 94 said:

There is a rubber boot that goes from door to pillar sometimes the wires can break in that area 

IMG_1671.JPG

I will try to check them, thanks a lot!

Share this post


Link to post
Share on other sites
26 minutes ago, Niklas Kjellström said:

I will try to check them, thanks a lot!

Where do I go from here? I've taken the door panel off but it looks hard, not knowing what cable does what. 

And it sure looks like someone's been here before, right?

Also, there was some visible moisture inside of the clear plastic film, maybe that could be the culprit?

 

IMG_20190730_184106.jpg

IMG_20190730_184208.jpg

IMG_20190730_184205.jpg

IMG_20190730_184110.jpg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Club Hybrid Poll

  • 218 Hybrid Reliability

    1. 1. If you were to consider buying a Hybrid model over 5 years old, would you be worried about the reliability of the Hybrid system?


      • Not really as Hybrid systems are always reliable
      • Not if it had a Manufacturers Warranty on the Hybrid system
      • I would not buy a Hybrid model over 5 years old