Recommended Posts

I have a IS250, 2012, and the windows mist up in seconds when the climate fan is on if the air con is not on.  This happens both in winter and summer.  Any fixes out there.

Thanks

Share this post


Link to post
Share on other sites

As far as I am aware its all in the settings,hopefully someone will elaborate further 

Share this post


Link to post
Share on other sites

Switch the aircon on!

Why do you ever have it switched off? Keep it on all the time.

Share this post


Link to post
Share on other sites
1 hour ago, johnatg said:

Switch the aircon on!

Why do you ever have it switched off? Keep it on all the time.

+1 to that

Share this post


Link to post
Share on other sites

.... also, you could have a blocked cabin filter thats not allowing air movement in the cab 

  • Like 1

Share this post


Link to post
Share on other sites

I just had this on a brand new Audi. Pressing recirculate fixed it.

Sent from my SM-G975F using Tapatalk

  • Like 1

Share this post


Link to post
Share on other sites

mist = moist. aircon takes moist out of the cabin, just leave it on at all times

Share this post


Link to post
Share on other sites

If you haven’t used you AC for a while it might smell a bit funky when first used, also check that the cabin/pollen filter is good ( not blocked or damp) and preferably use a activated charcoal type to reduce the build up of bacteria on it.

paul m

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.