Recommended Posts

I was mooching though eBay today and saw this.....

https://www.ebay.co.uk/itm/LEXUS-2013-19-VLite-CarPlay-iPhone-Android-Mirroring-Bluetooth-Camera-Kit-LEX89/183837945031?_trkparms=aid%3D111001%26algo%3DREC.SEED%26ao%3D1%26asc%3D20160908105057%26meid%3D5b35ee85c3854417b3632474f2800d76%26pid%3D100675%26rk%3D4%26rkt%3D15%26sd%3D333281955558%26itm%3D183837945031%26pmt%3D0%26noa%3D1%26pg%3D2481888&_trksid=p2481888.c100675.m4236&_trkparms=pageci%3A7d00121a-d4b0-11e9-b12e-74dbd180ef2f|parentrq%3A21230ee116d0a4b7b6be0706ffb54ee7|iid%3A1

Now having used CarPlay in the past and been quite impressed with it i'm quite interested to see if anyone else has tried this kind of equipment in the past and how they got on with it. Its a uk supplier so I have a little more faith in their post purchase support than buying from some random Far Eastern company.

 

 

  • Like 1

Share this post


Link to post
Share on other sites

Hi,

I bought this kit a few months ago and installed it on my 2is 2007 IS250. So far I haven't had any problems and I mostly use it for apple CarPlay. I tried it last night and it works with iOS13. I'll include the link to the article I posted on the forum regarding the installation on the 2nd gen IS but I'm yet to make a review on the unit.

Ismael

  • Like 1

Share this post


Link to post
Share on other sites

Anyone tried this on a is300h? Thanks 

Share this post


Link to post
Share on other sites

After asking the eBay seller a few questions I decided to take a punt and buy one.
The seller has been really helpful, always coming back to me quickly and getting the parcel out to me overnight as well.

In the box you get the control unit, a small box about 6”x6”, two custom looms to plug into the current wiring and an additional loom for some extras that you can install later.

Installation was pretty easy, took about 2 hour as I was taking my time, it is literally plug and play and the instructions are very clear as well.

Got it all fitted, fired it up and found it had an irritating screen flicker, every 30 seconds the screen would click on and off, pinged an email to the seller who told me I needed to deal with technical support for the manufacturer (Grom)
Pinged them an email, now because they are US based they seem to be almost the opposite time zone from me, this means that trying to get this issue solved became a bit prolonged, but at least there wasn’t a language barrier that you sometimes get with offshore support.

So a week later and 3 firmware flashes the system is sadly being pulled out of the car and sent back for a refund, every time they give me a new firmware the problem gets worse, to the point where I only have 1/3rd of the screen working when I’m using the Grom system, luckily I have been able to resort back to OEM without any issues.

It’s a real shame as it was pretty good value and easy to fit and use, had it worked and the tech guys hadn’t really messed it up then I believe it had the potential to be a good system.



Sent from my Iphone using Tapatalk

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Club Hybrid Poll

  • 304 Hybrid Reliability

    1. 1. If you were to consider buying a Hybrid model over 5 years old, would you be worried about the reliability of the Hybrid system?


      • Not really as Hybrid systems are always reliable
      • Not if it had a Manufacturers Warranty on the Hybrid system
      • I would not buy a Hybrid model over 5 years old