Recommended Posts

Hi have fault code POO51 coming up. 2010 RX450h.

Oxygen sensor Bank 2 Sensor 1. I believe this is the sensor closest to the front of the car. Does anyone know the part no? 

Having a few issues searching for it. Thanks

Share this post


Link to post
Share on other sites

Hi Barrie, here's a range of O2 sensors and their part numbers; https://www.rockauto.com/en/catalog/lexus,2010,rx450h,3.5l+v6+electric/gas,1444314,exhaust+&+emission,oxygen+(o2)+sensor,5132

A quick Google indicates back 2 sensor 1 is on the front of the engine underneath the coolant tank; 

4469a42s-960.jpg

https://www.clublexus.com/forums/rx-3rd-gen-2010-2015/841783-p0051-oxygen-sensor-bank-2-sensor-1-a.html

Will you be investigation and resolving this yourself?

Good luck.

  • Like 1

Share this post


Link to post
Share on other sites

Many thanks. Yes it'll be DIY. I haven't even had the chance to give it the once over and check its not loose/damp or anything. Had 5 minutes in work spare so plugged the OBD in and that came up. Reset and disappeared but came back on when I nipped out at lunch.

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Club Hybrid Poll

  • 313 Hybrid Reliability

    1. 1. If you were to consider buying a Hybrid model over 5 years old, would you be worried about the reliability of the Hybrid system?


      • Not really as Hybrid systems are always reliable
      • Not if it had a Manufacturers Warranty on the Hybrid system
      • I would not buy a Hybrid model over 5 years old