gavin77345

VSC and check engine light

Recommended Posts

Hi All. I'm a newbie here so apologies if this is a common question. 

I've recently bought a used Lexus IS250 2006 Auto. It's running great apart from an error that came up the other week, I get the VSC, stability symbol (car with skid marks icon)  and the check engine light comes on. Using an error scanner it said that it was my torque convertor, solenoid stuck on - error.

The car has done 140k miles and it has a full Lexus history but it's never had anything done to the gearbox from what I can see. Anyone else had this issue?

I've been reading up and many people say to do an oil change on the gearbox. Any help appreciated.

I'm tempted to get the gearbox serviced, but would like recommendations on any Auto transmission specialists near Kent (the Dartford or surrounding areas.)

 

Thanks

 

Share this post


Link to post
Share on other sites

There's a company that sells transmission oil on ebay, and they also advertise a transmission fluid change service. They are in your neck of the woods too. Look up Lexus or Toyota transmission oil, you should easily find there details that way.

 

Share this post


Link to post
Share on other sites

Funny enough - I have same issue with my old car which needs to be fixed before selling:

Screenshot_20200205-191314_Torque.thumb.jpg.ef3824f957029c11a59f80f48a3176fc.jpg

As said above, this should be fixed by replacing some gearbox oil/fluid - planning to do it later this week. If I remember right, there are no way to actually drain the fluid, so it is relatively log process of adding fluid and then waiting for it to drain.

 

Share this post


Link to post
Share on other sites

Thanks both for replying. Going to book it in to the garage to get the level checked. Will update how I get on.

Share this post


Link to post
Share on other sites

Hello. 
I have same problem with my on. The difference is my one is diesel and manual transmission. Also when I have this lights engine don’t have power at all. Any advice? Thank you. Sorry for my language 

Share this post


Link to post
Share on other sites

3 hours ago, Zawijak said:

Hello. 
I have same problem with my on. The difference is my one is diesel and manual transmission. Also when I have this lights engine don’t have power at all. Any advice? Thank you. Sorry for my language 

220 does not suffer from this problem.

Do you mean you have an engine warning light showing?

Share this post


Link to post
Share on other sites
8 minutes ago, Phil01 said:

220 does not suffer from this problem.

Do you mean you have an engine warning light showing?

 

Share this post


Link to post
Share on other sites

Yes plus vcs and car no power 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.