Recommended Posts

Mine haven't worked since I got the car. Is there a separate fuse for them or is it more likely pump issue in which case is it a difficult job?

Share this post


Link to post
Share on other sites

Jamie silly question but have you tried them with the headlights on first(common mistake)?

  • Like 1

Share this post


Link to post
Share on other sites

They get bunged up easily. If you don’t use them from time to time and forget they are there...

Share this post


Link to post
Share on other sites

8 hours ago, scudney said:

Jamie silly question but have you tried them with the headlights on first(common mistake)?

Exactly what I was about to say!

Share this post


Link to post
Share on other sites

Yeah lights definitely on. They don't seem to pop out or anything so assuming no power. before I start pulling things apart I thught Id see if fuses as always easiest option :)

Share this post


Link to post
Share on other sites

You reminded me that I had headlamp washers as I never use them. Had to check the manual to find how to operate, and bingo they work perfectly. Just changed the windscreen wipers, although they were ok, for the discounted denso ones I bought earlier from ECP. They are not the same as the Lexus ones which have an extra metal wind deflector on them. The seem ok and work fine, but I am keeping the old ones and will buy just the rubber inserts from Lexus as I did 5 years ago, if they are not as good.cheers, Roger

Share this post


Link to post
Share on other sites
2 hours ago, RgrWynne said:

You reminded me that I had headlamp washers as I never use them. Had to check the manual to find how to operate, and bingo they work perfectly. Just changed the windscreen wipers, although they were ok, for the discounted denso ones I bought earlier from ECP. They are not the same as the Lexus ones which have an extra metal wind deflector on them. The seem ok and work fine, but I am keeping the old ones and will buy just the rubber inserts from Lexus as I did 5 years ago, if they are not as good.cheers, Roger

Strangely, mine being an import it doesn't have headlight washers.  And I'm assuming it came from a warmer part of Japan because it doesn't have heated front seats either.  But it does have two screen wash reservoirs, one to wash the screen and the other to rinse off the screen wash with clean water!

Share this post


Link to post
Share on other sites
56 minutes ago, The-Acre said:

Strangely, mine being an import it doesn't have headlight washers.  And I'm assuming it came from a warmer part of Japan because it doesn't have heated front seats either.  But it does have two screen wash reservoirs, one to wash the screen and the other to rinse off the screen wash with clean water!

Now that is just being posh 😂😂😂

Share this post


Link to post
Share on other sites
9 minutes ago, RgrWynne said:

Now that is just being posh 😂😂😂

More than you think, my screen wash water comes from Harrods own natural spring, and it's flown from London to my house by pink feathered nymphs!

  • Thanks 1
  • Haha 2

Share this post


Link to post
Share on other sites
7 hours ago, The-Acre said:

Harrods own natural spring

I think that's the one in Peckham actually

Malc

  • Like 1
  • Haha 1

Share this post


Link to post
Share on other sites
5 hours ago, Malc said:

I think that's the one in Peckham actually

Malc

Damn, I knew I'd be found out!

  • Haha 1

Share this post


Link to post
Share on other sites
15 hours ago, The-Acre said:

Strangely, mine being an import it doesn't have headlight washers.  And I'm assuming it came from a warmer part of Japan because it doesn't have heated front seats either.  But it does have two screen wash reservoirs, one to wash the screen and the other to rinse off the screen wash with clean water!

It’s exactly the same with mine.....we do have a flare tube though 😀

Share this post


Link to post
Share on other sites
29 minutes ago, steve2006 said:

It’s exactly the same with mine.....we do have a flare tube though 😀

And my flare tube (complete with flare) expires this year!

 

IMG_20200506_112224695.jpg

Share this post


Link to post
Share on other sites
2 hours ago, The-Acre said:

And my flare tube (complete with flare) expires this year!

 

IMG_20200506_112224695.jpg

Surprised to see that, they are normally removed before shipping for obvious reasons. If your LS does ever break down you can be totally JDM and set it off behind the car 😀

Share this post


Link to post
Share on other sites
55 minutes ago, steve2006 said:

Surprised to see that, they are normally removed before shipping for obvious reasons. If your LS does ever break down you can be totally JDM and set it off behind the car 😀

It surprised me as well.  I did leave it at home last year before our Eurotunnel crossing!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.