Sign in to follow this  
smitha

Folding mirror won’t unfold

Recommended Posts

My RX400H passenger side power mirror folds in while making a loud clicking noise , then won’t unfold. I’m happy to strip it down but any ideas what I’m looking for ? Thanks 

Share this post


Link to post
Share on other sites

Could be the teeth on the clog or wheel are worn,and therefore causing the clicking noise,try spraying the inside of the mirror with some wd40 and see if this helps 

  • Like 1

Share this post


Link to post
Share on other sites

As above but I would use a dry PTFE lube spray (as used on MTB chains) WD40 is rather thin, more a water dispersant. Either way, looks like a strip-down required.

  • Like 2

Share this post


Link to post
Share on other sites

On 6/30/2020 at 7:25 AM, NemesisUK said:

As above but I would use a dry PTFE lube spray (as used on MTB chains) WD40 is rather thin, more a water dispersant. Either way, looks like a strip-down required.

Can I strip this from the outside without taking the whole unit off the car . I did consider buying a second hand unit and swapping the parts reusing my case which is in good condition. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this