Do Not Sell My Personal Information Jump to content


FM Radio issues Ct200h


Recommended Posts

Hi everyone,

                    Has anyone had issues with the Ct200h where it won’t pick up any fm radio. This is on a Ct200h 2011 old type multimedia system. The system will play Spotify, am channels but won’t pick up fm. Tried a new aerial from another Ct200h and have just removed all the trim around the dash and pulled the radio out for a closer look. All connections are made at the back of the radio. I also removed the rear roof lining partly and disconnected the plug at the antenna. Performed a continuity check from the antenna plug to the plug on the back of the radio and all seems ok. On the antenna cable at the radio itself there is two cables on the plug so I’m wondering if there is a booster in the circuit, or is the co ax picking up interference from somewhere else in the vehicle, causing me to loose all stations. Would be grateful for any advice.

Thank you

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...




Forums


News


Membership