Do Not Sell My Personal Information Jump to content


Recommended Posts

I've been getting a clunk in the front suspension. After some investigation it seems like the strut rod bushing was a common cause. This morning I took them off for a look, pretty easy job which is nice. However I was expecting to see a lot worse in the regards cracks in the rubber. What does every think of the these? Are they due replacement?

PXL_20210405_122030346.jpg

PXL_20210405_122019069_MP.jpg

PXL_20210405_122800363.jpg

PXL_20210405_122104872.jpg

PXL_20210405_122816605.jpg

PXL_20210405_122807219.jpg

Link to post
Share on other sites

More likely to be the upper arm bushing check by lifting the front wheel off the ground an levering up from the bottom of the tyre with a bar ,at the same time grip the bushing on the end of the arm that connects to the top of the hub strut and it will move about if worn .

Link to post
Share on other sites

OK, so I think the strut rod bushings are still good so will refit.

Will check the drop links, hopefully its that. If not then UCA is the next bet, and expensive one! 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...




Forums


News


Membership