Do Not Sell My Personal Information Jump to content


No power to dash no indicators no window power but starts


Recommended Posts

Hi Im new to Lexus o.c I have a problem with a 2008 220d 

It started with a dead Battery having not started for 2 months the owner started the car with jump leads and on first drive (everything electrical was working) engine cut out due to dead Battery so I was called I'm a relative to the owner to look at it by the time I got there he tried to jump start again admitting he had the jump leads the WRONG WAY ROUND !

I put jump leads to my running van to try and put some volts back into Lexus Battery for 15 mins voltage read 13.8v on Lexus Battery with my engine running after 15 mins I disconnected jump leads to find Battery read only 3 volts so Battery duff so new Battery fitted car starts up but no elec windows/indicators/heater/wipers not working all dead so hopefully MAIN FUSE blown but cannot find  location all fuses checked ok under dash passenger side but no 12v showing on any of them fuses under dash all dead, any help would be much appreciated thanks Bryce.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...




Forums


News


Membership