Do Not Sell My Personal Information Jump to content


Recommended Posts

Hi All, I am not sure if this is ok to be here or needs to be in Engine and Transmission so Mods please feel free to move.

So this weekend i nipped across town and on the way back i nipped to maccys and while in the drive through it popped up Check Hybrid System, Check VSC and Check ECS. It was raining hard and i made it back home although it was a bit sluggish (Obviously Hybrid System not running, ABS and TC not working) I have just had my second jab and was feeling crappy yesterday so didnt have chance to look at it. Got back in the car this morning and it was still showing the error. I drove to work (Across town in traffic so nothing over 45mph) turned the car off and back on a couple of times and the Check VCS and Check ECS went away but it was still showing Check Hybrid System.

So i nipped out in my break and took off the cover in the boot to the Battery and the Negative terminal was really badly corroded. So i am going to replace that and see if it helps/sorts it.

I have done a bit of a search and can find a replacement original but they are £229! Can i replace it with a standard Battery same size/power/terminal config? As i understand it, it will remove the temp sensor on the Battery but would this cause an issue with the ECU/Fault Modules?

Does anyone have a recommendation on a brand/model Battery to replace it with? 

I have also ordered a Mini-VCI cable and software to do some further diagnostics (Also wanted one to further my P0017 error i still have but not sorted).

As always any help would be appreciated. 

EDIT: I have just found this listed showing it works for the 2006 GS450h is there any issues getting one of these and fitting?

HEAVY DUTY BOSCH CAR BATTERY FOR LEXUS S4026 | eBay

Link to post
Share on other sites

Before spending any money just clean up the Battery terminals to begin with and see if it helps.

One trick to get rid of the crud on the terminals is to pour boiling water on them, but that's not practical with a Battery in the boot. Take both pos and neg clamps off and give both the clamps themselves and also the Battery posts a really good scrubbing with wire wool and make sure they are tight when you reconnect them. Do the same at the other end of the earth strap where it bolts to the body.

Keep us posted with your progress.

  • Like 1
Link to post
Share on other sites

Thanks Herbie, i had already ordered it as i thought it was prudent after 15 years of use. Fitted in the rain this lunchtime and all seems good so far. Will clean up after i finish work and test it driving home. 

Link to post
Share on other sites

I'd use an OBD reader to check the codes as well, they normally tell you exactly what the issue is.

Sounds like it probably is the 12V in this case but always a good idea to check before spending that much £.

If you haven't got one, worth picking one up for around £20, even if you don't need it now, its not Lexus or model specific so
you can use it from car to car.

Link to post
Share on other sites

I do have one but unfortunately i cant use it.. I used to have a Pixel 2 and it worked fine with Torque but it wont work with Iphone. I now have my mini-vci cable and need to get the software setup. IIRC the OBD2 reader will just poll the information from the ECU but the Mini-VCI setup with the laptop and software can poll all of the diagnostic modules and give a more in-depth insight into the issue.  

Link to post
Share on other sites
4 hours ago, ZXSpectrum said:

I do have one but unfortunately i cant use it.. I used to have a Pixel 2 and it worked fine with Torque but it wont work with iphone. I now have my mini-vci cable and need to get the software setup. IIRC the OBD2 reader will just poll the information from the ECU but the Mini-VCI setup with the laptop and software can poll all of the diagnostic modules and give a more in-depth insight into the issue.  

Yeah I have similar on my laptop, but the OBD2 reader is much more convenient to keep in the car 😉 

Link to post
Share on other sites

Oh yeah deffo.. I will look at grabbing a new one that is IOS compatible when i get chance and i also like that i can have another live readout of information and simple diagnostics.

All seems to be working now and no Check Hybrid System and Hybrid seems to be kicking in all ok now.

One Odd thing i did notice on the way home is that all but the driver power window has now stopped working. It was working fine before i changed the Battery, could i have blown a fuse while changing the Battery or is it more than likely that i have not tightened the Battery lugs enough?

Link to post
Share on other sites

You need to reset the windows. Drive each window up and down with its own switch (ie in its own door). Pause for a few seconds at the down point. Then they will all work from the drivers door panel.

Link to post
Share on other sites

Unfortunately they dont seem to be working on their own switches or from the driver switch panel. I am going to double check the Battery terminals and ground point at lunch just to rule that out. 

Is it possible that in fitting the new Battery i have blown a fuse? Is the drivers window on a separate fuse to the other 3?

I did also notice while removing the Battery there are 3 fuses on a cable that clips to the Battery hold down. Are they related? I was going to check those just in case i had dislodged them when removing the Battery.

Link to post
Share on other sites

Well cleaned up all the terminals and ensured they were tight. Even cleaned off the metal where the earth strap fixed to ensure its getting a good ground and still the same..

Couldnt find the fuse that is related to the power windows in the fuse box so if anyone could point me in the right direction it would be appreciated.

Guess its searching time. 

Link to post
Share on other sites

Well another update.. I have sorted the window issues. I had accidently pressed the window lock button so the other windows wouldnt work on their own switches. I sorted them now and they work. 

But after nipping to sainsburys i went over one of their rubber speed bump things and went back to the Check Hybrid System, Check VSC, Check ECS.

I am hoping its just bad connection to one of the ABS sensors and have it booked in for Oil and Filter at my local garage tomorrow so will get him to check all the connectors and clean them up. If that doesnt sort the issue then i will get the diagnostic software installed on my laptop and see if that gives me a better idea of what the issue could be.

 

Link to post
Share on other sites

Yet another update.. I drove it home last night with the error still flashing away and hybrid system not working. Pulled off the Battery terminal for a couple of mins and started up all ok without the error. Drove it round the block and it was fine. Woke up this morning, still no errors but while driving to the garage i was stuck behind a bus waiting to go round it. When i pulled away i felt a bit of resistance from the rear of the car and the error message popped back up. 

I am getting an oil change and the mechanic is going to check all the ABS sensors and connectors along with all the disks and pads (Pretty sure i am due them).

Could this be the result of a sticking/seized rear caliper throwing up issues with the ABS?

i have to grab a laptop i can run Windows 7 32Bit from a friend so i can run techstream so might be a couple of days before i can get that sorted.

Link to post
Share on other sites

Well it looks like my suspicions are about right.. Looks like both calipers on the rear are seized, one a lot more than the other and it has caused damage and corrosion to the disk. So i have ordered some new disks and pads but i am struggling a little with replacement calipers. Eurocarparts seem to have padgid ones for £181 including £48 surcharge. Is this about what i am looking at? I will post in the Brakes section to keep it a little tidy. 

Link to post
Share on other sites

Hahaha... Richard, you must be a bloody mind reader! I was going to give you a call this afternoon to discuss but I got a little busy! 
 

I will call you tomorrow at lunchtime if that is convenient for you?

Link to post
Share on other sites
2 hours ago, hybridbatterysolutions said:

I'm not quite that clever!! Yes by all means, I should be around.

He may not be a mind-reader but he is the Battery whisperer 😉

Nice guy and very knowledgeable.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...




Forums


News


Membership