Do Not Sell My Personal Information Jump to content


Recommended Posts

Good evening everyone,

My 2010 220d (75k miles) went into limp mode yesterday but strangely only the engine warning light and the wheel spin/skid indicator lights are on and there is no 'Check VSC' warning message in the display. This is my 2nd 220d so I'm used to the 'Check VSC' warning and the three warning lights but this is different.

Anyway, switching off the car clears the limp mode but not the two warning lights and the limp mode returns within a mile or so. I've ordered an OBD reader but don't have it yet.

Worth saying that today I stripped the EGR value and cleaned, etc. The car runs better but still goes into limp mode with the two warning lights even after the EGR was cleaned. 

Any thoughts very much appreciated.

Scott

Link to post
Share on other sites

33 minutes ago, Craignaneun said:

Good evening everyone,

My 2010 220d (75k miles) went into limp mode yesterday but strangely only the engine warning light and the wheel spin/skid indicator lights are on and there is no 'Check VSC' warning message in the display. This is my 2nd 220d so I'm used to the 'Check VSC' warning and the three warning lights but this is different.

Anyway, switching off the car clears the limp mode but not the two warning lights and the limp mode returns within a mile or so. I've ordered an OBD reader but don't have it yet.

Worth saying that today I stripped the EGR value and cleaned, etc. The car runs better but still goes into limp mode with the two warning lights even after the EGR was cleaned. 

Any thoughts very much appreciated.

Scott

I think you really need to wait until your code reader arrives, I've tried many times over the years to "guess" but an accurate diagnosis is the way to go.

Link to post
Share on other sites
1 hour ago, The-Acre said:

I think you really need to wait until your code reader arrives, I've tried many times over the years to "guess" but an accurate diagnosis is the way to go.

Thanks, I'll report back once I have the OBD - probably Thursday.

  • Like 1
Link to post
Share on other sites

Hi,

Original poster here; OBD received and fault code(s) interrogated as follows: P2002 (fault & pending).

When I clear the fault the car runs ok for about a mile and then engine dash & anti-skid lights come on and then next time you change gear the car goes into limp mode. Worth also saying that the car is really hesitant in low revs after the fault has been cleared.

Looking at google this appears to be DPF related? If so what's the recommended next step please?

Scott

Link to post
Share on other sites

Does your diagnostic have data logging/live reading function? DPFs have pressure sensors for pre and post filter pressure. I'd be looking to see if there is a big pressure difference as this would indicate a blockage.

Link to post
Share on other sites

Update

So I've put the car to the local garage with a proper diagnostic machine.  The code it spits out is: "P2002 NOx separator efficiency lower than threshold (bank 1)".

The garage are saying that the O2 Lambda sensor needs changing (part 89467B) and Lexus are quoting £625 + vat.

I've ordered an original Toyota part (89467-53010) from eBay for £110 but it won't arrive until Monday.

One other thing: the DPF was checked and isn't full.

Appreciate any thoughts as the feeling I get is that there's not a 100% confidence that this will cure the problem.

Scott

Link to post
Share on other sites

So needless to say, replacing the O2 sensor didn't make any difference.  So DPF coming out to be manually cleaned. Here's hoping this doesn't turn into one of these marathon & expensive sagas....

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...




Forums


News


Membership