Do Not Sell My Personal Information Jump to content


Recommended Posts




Don’t understand why it’s not working!

Link to post
Share on other sites
On 5/27/2021 at 8:11 PM, ColinBarber said:

Ouch. Has that failed from the inside out, or has someone left a spanner in the engine bay?

yes inside decided to launch itself ! No noise no loss of power first I new was it wasn't cold fitted a used pump yesterday had it gassed today its Freezing !!!!

 

  • Like 3
Link to post
Share on other sites
On 5/28/2021 at 9:04 PM, isrod said:

yes inside decided to launch itself ! No noise no loss of power first I new was it wasn't cold fitted a used pump yesterday had it gassed today its Freezing !!!!

Would be interesting to know where you got the spare compressor and overall costs of fixing it?

Link to post
Share on other sites
On 6/1/2021 at 1:41 PM, Linas.P said:

Would be interesting to know where you got the spare compressor and overall costs of fixing it?

I picked up a compressor on ebay and fitting was very easy jack car up and remove under tray two 10mm bolts holds pipes on and four 12mm fix it to the block it drops right out of the bottom.

I had it gassed at a local garage full vacuum and gas pressure test and dye added and correct amount of oil in system.

Luckily I did not have to replace the dryer as I had only allowed the system to be empty a few days.

The compressor may only last a year or maybe more as I have no idea what the miles are on the S/H unit.

 

 

  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...




Forums


News


Membership