Do Not Sell My Personal Information Jump to content


Recommended Posts

Hi, my name is James and I am a new member. I have an RX400h SE 2007. There is a problem with the ABS, P/S and the AWD. The ABS stopped working suddenly and now the spedomoter has ceased. Have called Lexus this morning, waiting for call back. Can anybody help or recommend a reliable service engineer in NW London. Near Hendon if possible. Thanks, James

Link to post
Share on other sites

8 minutes ago, JRSM said:

Hi, my name is James and I am a new member. I have an RX400h SE 2007. There is a problem with the ABS, P/S and the AWD. The ABS stopped working suddenly and now the spedomoter has ceased. Have called Lexus this morning, waiting for call back. Can anybody help or recommend a reliable service engineer in NW London. Near Hendon if possible. Thanks, James

Welcome James. Sorry to read of your problems. See if this helps.

MORE LEXUS INDIE RECOMMEND.docx

Link to post
Share on other sites

As someone mentioned in the other thread, you need to get the codes read. One thing I can say for sure is that if the brakes have needed bleeding, you need to use the Techstream software to do that, so if the garage who repaired the brakes didn't use it, that may be the problem.

Link to post
Share on other sites

Thanks Herbie.please see attached diagnostic print out. Regards James

IMG_20210603_205820.jpg

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...




Forums


News


Membership