Do Not Sell My Personal Information Jump to content


Intro and bad news...


Recommended Posts

Greetings all!

 

Just thought id make my first post following me stalking you all the past few weeks😁. Just bought my first Lexus its a 2008 GS450h. Have had the car almost a month now not done many miles. Had it almost completely serviced minus the Fuel filter and coolant. 

Onto the bad news.... im a victim of the P0017 Cam sensor Bank 1 Sensor B. Now ive heard the many possible fixes and causes so i have had the service and the sensor changed. Which from what i have read is 2 of many causes. Sidenote i replaced the sensor that isn't angled as i wasn't sure which bank was which. The engine isn't running rough the fuel is sealing correctly also MPG seems good which is now leading me to believe it is the dreaded chain stretch. 

 

Which brings me to what should i do next. It was a private sale so cant really return and either way i dont really want to return it. Does anyone know how much a fix should cost? Does anyone know a decent Lexus specialist in the midlands? The closer to Birmingham the better?

 

Thank all!

 

Link to comment
Share on other sites


First step in the service manual for this error is checking and correcting the timing. If the timing is NOT off - it says "replace the ECM (i.e. ECU)". Therefore - pretty certain that it isn't the sensor itself. Bank 1 on the 2GR-FSE is UK (RHD) driver's side, which is where the high pressure fuel pump is... which complicates the "remove the valve cover" matter a bit. Very rare and/or weird on a 2GR-FSE... What's the mileage, and what kind of driving/oil has it seen, if I may ask?

Re: fuel filter - it's not the easiest or cheapest of jobs, no wonder you haven't done it yet 🙂

Link to comment
Share on other sites

Hi, firstly thanks for the reply. I believe its had 5w-30 as the last service was done by indy garage im unsure, All services before that was all Lexus dealer. Ive now put Castrol Edge 0w-30.

 

In regards to system messages ive got a TPMS sensor issue also so it always says check system or something along them lines lol. Its currently at 111k miles. The sensor i changed was on the passenger side i believe thats what my mechanic said as i supplied the sensor it was the angled one i think.

Link to comment
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...




Forums


News


Membership