Do Not Sell My Personal Information Jump to content


My RX300 - steering wobble when driving :(


Recommended Posts

Hello All,

Just in case someone has any thoughts. ( A forum search didn't show up anything for an RX. )

My beloved but old ( 19 years ) RX300 this morning developed a wobble. Having been out and about, with no recent problems/garage work etc., just as I was nearing home, I noticed a steering wobble. It occurred as I was driving, though I was not braking or doing anything untoward. It reminded me of when you drive slowly and quickly turn the steering wheel left and right. I was holding the steering wheel steady but the car at about 35+ MPH was veering left and right. It did not feel safe, so I slowed down and fortunately was within a minute of home, so drove slowly and parked. The almost new tyres all look fine and the car corners/heights all look fine.

I guess it's steering related? There is a garage nearby but not sure I relish the short journey.

If anyone has any reflections...?

Link to comment
Share on other sites

29 minutes ago, CypressPhil said:

Hi Piers

My money would be on a sticky brake calliper. Had exactly the same thing on an IS200. 

You can check this by seeing if one wheel is running hotter than the other after a drive.

 

1 hour ago, PCM said:

The almost new tyres all look fine and the car corners/heights all look fine.

Check your wheel nuts are torqued correctly, if the wheels have been off recently.

  • Like 1
Link to comment
Share on other sites


Well...

I'm told it's a snapped, badly corroded rear suspension arm.

The part is on order now.

It's also suggested both be changed. Which sounds reasonable to me given the age of my car.

  • Like 1
Link to comment
Share on other sites

15 minutes ago, PCM said:

Well...

I'm told it's a snapped, badly corroded rear suspension arm.

The part is on order now.

It's also suggested both be changed. Which sounds reasonable to me given the age of my car.

At least not terminal!

  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...

1 minute ago, Barry14UK said:

... I am surprised this was not picked up earlier at MOT, as clearly deteriorated over long time.

And me, given the affect it had...

Link to comment
Share on other sites

  • 1 month later...
On 2/22/2022 at 7:16 AM, PCM said:

The lesser of the two corroded/broken parts.

Both replaced now and back to normal.

 

IMG_2823.JPG

@PCM well used

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...




Forums


News


Membership