Sign in to follow this  
TRL Performance

Jzs161 Vvti Throttle Pedal Sensor

Recommended Posts

JZS161 Aristo V300 Vertex

VVTi Throttle Pedal Position Sensor

Anyone know of a VVTi Supra or Aristo V300 being broken or do you have some Parts for sale?

I need a throttle pedal position sensor for the Lexus V300 Vertex

It's the same part on the Altezza, Aristo, NA Supra and TT tiptronic Supra.

NOTE this is NOT the throttle POSITION sensor it IS the PEDAL sensor. The one connected to the cable on the throttle body. So on the left of the throttle body (when viewed from the front of the engine)

It's electronically linked via a magnetic clutch to the actual throttle control motor.

Symptom....

I keep getting VSC, TRACand Engine Check light on and when I grab the fault codes it's fault code 19 which is Throttle Pedal Position Sensor.

I measured the sensor and only get a reading from ONE of the variable resistor paths. The other is open circuit. It's drives O.K. and then under breaking and steering the VSC lights up and goes into limp home mode.

I've also notice the brake feels weird. It brake really well right until the car is about to come to rest when the pedal just falls to the floor. A bit alarming.

Anyone recommend anything else it could be. I think maybe the ABS side of things is a bit suspect? Almost like the ABS isn't able to modulate the pressure from the master cylinder or something? Take your foot off and back on and the pedal feel resumes as it should.

Under heavy breaking the ABS does kick in and stops on a knife edge.

Thanks

Pete

Share this post


Link to post
Share on other sites

May be difficult finding a used part. You should be able to order one from any Toyota dealer.

Share this post


Link to post
Share on other sites

My JZS161 V300 had the same symptom but the fault turned out to be the sensor on the throttle body, not the pedal sensor. Exchanged hard-earned AUS$600 for a new $10 part from the Lexus "how much you got?" dealer and the problem went away. I've had the dud one gold plated and mounted to symbolise the experience.

Share this post


Link to post
Share on other sites

the soarer with trc has the same type of braking problems as your having, the electric pump (accumulater) and pressure switch are possible faults. have you changed the brake pads lately.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this