Sign in to follow this  
Gavin G

Is200

Recommended Posts

My IS200 has seemed to develop a squeaking type noise which I think maybe coming from the front passenger seat. It only happens when going over bumps or on uneven road surfaces.

Don't think its there when there is someone sitting on the seat although can't be 100% sure.

I seem to remember other threads on this so does anyone know if its a common problem on the IS and how can it be fixed?

Thanks in advance,

Gavin :)

Share this post


Link to post
Share on other sites

mine does it aswell gav,ive tried allsorts,it stops when someone sits in it,i give in :crybaby:

Share this post


Link to post
Share on other sites

When it's making the noise, try slackening your seatbelt or pulling it tighter.

If it quietens for a while, it's likely the stalks that you click the seatbelt into.

Dealer replaced mine - nice and quiet now B)

Others have had success by periodically lubricating where they attach to the seat.

[edit] Hmm, having re-read original post, this might not be relevant :duh:

Share this post


Link to post
Share on other sites

i have the same thing, its so annoying. i have tried everything, lubricated every visable point i could and still nothing.

even my driver seat has a squeak coming from the inside somewhere? aghhhhhhhhh. and that combined with the sunroof cover sqeaking makes me think im in a damn for somwtimes

Share this post


Link to post
Share on other sites
i have the same thing, its so annoying. i have tried everything, lubricated every visable point i could and still nothing.

even my driver seat has a squeak coming from the inside somewhere? aghhhhhhhhh. and that combined with the sunroof cover sqeaking makes me think im in a damn for somwtimes

such good quality cars arnt they ;) well rubbish :)

Share this post


Link to post
Share on other sites

I suspect mines may be coming from inside my passenger seat too. It wasn't always there though, just has started recently.

Have tried holding the seatbelt stalk so its not that :blink:

Share this post


Link to post
Share on other sites

hmmm, squeaky seats, lubrication, what have you lot been upto?

Share this post


Link to post
Share on other sites

Mine had similar issue, found to be 1: Sunroof surround black strip and 2: The seat belt loop thing on pillar: both replaced under warranty and silence is restored, Wd40 was no good this time. Common issues so i was advised.

Share this post


Link to post
Share on other sites
hmmm, squeaky seats, lubrication, what have you lot been upto?

:ph34r::ph34r:

say no more!

Share this post


Link to post
Share on other sites

I had the same problem, got it sorted by Lexus, :) , they say its the base of the seat and needs a replacement.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this