Sign in to follow this  
devdale

Is200 Engine Uneven Speed Change

Recommended Posts

Has anyone experienced uneven throttle response leading to engine acceleration and deceleration. At about 1500 to 2000rpm in second gear in traffic queues when trying to gently increase speed there is a sudden lurch and when slowing down again the engine suddenly slows. All leads to a jerky ride in slow traffic. All else seems OK with the engine. Done about 35,000 miles and serviced normally. Any advice? Thanks. :unsure:

Share this post


Link to post
Share on other sites

Think this is normal and something to do with the electronic throttle or something?

Edited by aido

Share this post


Link to post
Share on other sites

Thanks for the link. Could be the throttle like the replies say. It is not mechanical (clutch, gearbox). I don't remember it happening from new though so something may have altered. The throttle is strange though. If you slam your foot down it takes about half a second to respond. You can have your foot off again before it changes revs. Must be the fly by wire throttle? Shame as I seem to spend most of my time in traffic jams at the moment and it's hard to keep it above 4000 revs!! ;)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this