Sign in to follow this  
jasonco

Se-l Suspension Issue?

Recommended Posts

My new RX300 SE-L seems to prefer making the passenger side higher than the drivers. I parked it up today, upon walking back noticed that the left hand side was 2 inches higher than the right. Started it and it returned to normal.

This got me thinking, over the last few weeks it has been not holding the road as well as it did previously + a feeling of boucy'ness (is that a word). I am wondering if it might be doing this whilst I am driving as well as when it is parked.

Anyone seen similar behaviour???

Share this post


Link to post
Share on other sites

I've heard of another SE-L with suspension problems. Take it straight to your dealer and get it fixed under warranty.

Share this post


Link to post
Share on other sites

Well after two visits back to my dealer (the 1st time they couldn't find anything wrong) they finally fixed it. Water had leaked into one of the sensors and was giving duff info to the computer.

They (Lexus Reading) did a sterling job repairing it....

:D

Share this post


Link to post
Share on other sites

Hi,

I am having a similar problem with my lexus but no warranty.

Did they replace your sensors?

Share this post


Link to post
Share on other sites

Hi,

I am having a similar problem with my lexus but no warranty.

Did they replace your sensors?

I have an 03 rx300 sel and have had two bad experiences with the suspension....the first was sorted as a broken wire found (after a lot of threats about nearly £2000 to fix!) and the second is corrosion around the sensors which leads to bad signals to the computer and the system shows as being turned off.....a good clean of the sensors and some wd40 and a fair amount of prodding etc has don the trick......no new sensors yet!

Share this post


Link to post
Share on other sites

Hi,

I am having a similar problem with my lexus but no warranty.

Did they replace your sensors?

I have an 03 rx300 sel and have had two bad experiences with the suspension....the first was sorted as a broken wire found (after a lot of threats about nearly £2000 to fix!) and the second is corrosion around the sensors which leads to bad signals to the computer and the system shows as being turned off.....a good clean of the sensors and some wd40 and a fair amount of prodding etc has don the trick......no new sensors yet!

Share this post


Link to post
Share on other sites

I have a similar problem with my air suspension.

My orange "off" light has just started to blink and the height adjustment has stopped working. How easy are the sensors to access and clean?

Share this post


Link to post
Share on other sites

Hi,

Are there any obvious warning signs that the air suspension is about to fail?

Also, can the air suspension be set to off (may be a daft question), so in the event of failure the car is still driveable at the correct ride height? Probably a better question is can the air suspension be overridden?

I am in the market for another RX and will be viewing an SE-L on friday.

Regs

Jules.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this