Sign in to follow this  
franmac

Dead Stereo

Recommended Posts

Have a dead stereo after a little accident with a set of jump leads !!!!!

Blew a main fuse and three other smaller fuses. All replaced now and everything is working fine, but stereo is dead. Clock won't hold the time either. Every time ignition is switched off clock resets to 1:00 . Have checked all fuses in passenger and drivers footwells, as well as under bonnet.

Have checked leads coming to rear of stereo and have power coming to the headunit (constant and switched)

Going to disassemble headunit tomorrow to see if I can locate an internal fuse.

Any advice, suggestions or info. would be appreciated.

franmac.

Share this post


Link to post
Share on other sites

And just in case this turns to total disaster :duh: :duh:

anyone know where I'd locate a bottom cd loading headunit. BTW Car has no amp.

franmac

Share this post


Link to post
Share on other sites

Sounds like you still have a blown fuse if the clock is also losing it's time.

Share this post


Link to post
Share on other sites

Other than the two footwells and under the bonnet in front of the Battery, anybody know where there are other fuses that I can check ? Don't really want to pull the headunit apart unless absolutely necessary.

franmac2.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this