Sign in to follow this  
taspland

Newly Acquired Aristo Tt '95

Recommended Posts

Hi,

I am the v proud owner of a Aristo TT '95. However the vehicle does not have a owners hand book and I was wondering what the Auto Airpwr button near the centre console arm rest does? Also when the little engine light comes up what does that exatcly mean, service due? or more serious?

Many thanks

Tom from Surrey

Share this post


Link to post
Share on other sites

Hi Taspland,what i can tell you is on the uk spec car,the PWR switch when switched on followed by a light on the dash,it will hold your car in its gears for a longer period rather than changing gear at lower revs.

Share this post


Link to post
Share on other sites
Hi Taspland,what i can tell you is on the uk spec car,the PWR switch when switched on followed by a light on the dash,it will hold your car in its gears for a longer period rather than changing gear at lower revs.

I dont think thats the switch that I need to know about, the one you are referring to is the ECT switch for the autotrans mode toggle. I have a switch that has Off, low, high, and other setting but has the title Auto AirPwr.

Thanks

Tom

Share this post


Link to post
Share on other sites

Hi Tom,

The toggle you'r on about is the "Auto Air Purefier", this will filter the incar carpartment, the filter is in the boot on the right hand side. It works with the fan controls, if you leave it on "Auto", it will speed up and slow down with the speeds of the fans. If on Low or High, it's then in all the time. The fans for this are located on the rear parcel shelf under what looks like speaker grills, one left and one right - either side of the centre sub.

The engine light can be caused by a lots of things from loss of pressure in the coolent to an ECU error for firing. As far as servicing, you should have the oil done every 6 months ideally, the rest can be done once a year depending on milage.

I'm in the middle of getting a manual sorted out for these, takes a time due to translation required for this.

Nice to have another Aristo in the Club - Welcome

BR

Paul

Share this post


Link to post
Share on other sites

What was the cause of the engine light?

That was the faulty speed sensor. ECU was all confused. as you can see in the vid everything is clear when started.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this