Do Not Sell My Personal Information Jump to content


Speedo Cluster


franmac
 Share

Recommended Posts

Been having a problem with the fuel gauge on my 2000 reg. IS. Not a major issue just a bit annoying thats all. Went into a local breaker yesterday and came across a 2002 IS. Asked the guy in charge if I could try the cluster from the 2002 in my 2000 to see if it would cure my problem.

Anyway I put in the cluster from the 2002 and the fuel gauge and all warning lights worked perfectly except for the ABS warning light was on. Reset the ECU but still had the ABS light on.

Plugs at the back of the clusters were identical, only difference in clusters that I could see was the MPG gauge and the TEMP gauge were the opposite way around.

My question is this, was the 2002 cluster faulty or are they just not compatible ?

So near and yet so far ....... it even had the right mileage on it .....

franmac

Link to comment
Share on other sites

I don't know the real answer, but it could be because the newer cars have brake assist and ebd, so it may have thought there was something wrong with the braking system. Sounds a little ridiculous to me too but dunno what would trigger the light in the first place

Link to comment
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...




Forums


News


Membership