Do Not Sell My Personal Information Jump to content


Acceleration Problems!


apsaauga
 Share

Recommended Posts

Hello guys, some time ago i noticed that my acceleration is ****ty. Realy, it got worse and i don't know why :yack: it seems that acceleration is slower in the 1 and 2nd gear when lifting, i mean longer to go to 6 RPM. But the worse is, when i go in 3 - 6 gear. For exsample, i go in 3rd gear in 40km/h then i accelerate to 60, and go back to 40, ride a bit longer in that speed, and hit the accelerator, and s :tsktsk: happens, it is slow and not smooth, besides sometimes i feel vibration in pedal when i push it :excl: help me guys, i am sad about that, i want to go to service, but they may say it is normal, fu :tsktsk: it is not!!! So what may be the probs? Filter(it is quite dirty), system, spark plugs?

I hope, You'll help me

Link to comment
Share on other sites


Try resetting the ECU - it worked for me & try putting some Optimax in it for a month and see if that helps!

Resetting ECu helps for a short time i think :blink: And optimax, as i understand it is better fuel, i don't have the exact one in my country, but i'll try NITRO 3000. Besides, could that be the fuel filter problem? Feels like car twitches a bit when hardly accelerate.

Link to comment
Share on other sites

Besides, when the car is cold, i mean standing whole day in quite cold weather, car drives bad, the engine has no power at all, i am not talking about high revs at all. It get better when temperature gets to still position. I did't noticed that for exsample half year ago :angry:

Link to comment
Share on other sites


I don't think it's the fuel filter. You could try a fuel injector cleaner and it may be worth looking at the spark plugs to see their condition.

fuel injector cleaner is something that You mix with fuel, right? And about spark plugs, i asked few months ago in Lexus service to check them out, they said, that they must be changed only when the clock shows ~80 000 km? Nonsense. besides, when i asked them to check them out anyways, they told me that it is hard to get them checked! Is it truth? or can i check them myself?

Thanks

Link to comment
Share on other sites

yes injector cleaner is just added to the fuel tank, the spark plugs are meant to be changed at 96,000kms.

it is not hard to change or look at them at all, you need to remove the air filter housing and the intake ( the big black bit of plastic on top of the engine)

when u have done that, you will see 6 small black boxes on top of the engine head, u need to remove these and the electrical connection, underneath are the spark plugs - u will need a spark plug socket and a ratchet to remove them.

should take you about 30 mins to change/check the plugs.

Link to comment
Share on other sites

  • 2 weeks later...

I think i am in trouble!! Now the acceleration is really shi**y. It even looks like car has 2 VVTI's?:) One is on 4500 RPM, other lower. It is getting worse! One day (not the only one) i was going home, 1, 2nd gear fine, but the 3rd was bad, i shifted it in, and car didn't accelerated for about 2 sec! Like it choked. Same with 4th gear. Tried to slow down and floored again. It was the same. I stoped, turned the engine of. Went to the shop, came back, started, looked normal again! What is that? i changed stock air filter, checked the spark plugs, they were fine, for checking if it was the fuel filled the gas tank with the 98, and not as usual with 95. Any advice?

Link to comment
Share on other sites


did you replace the air filter for a lexus/toyota one?  also check that the vacuum hoses that are below the throttle assy have not come of or are split.

Yes with the original toyota/lexus filter. And i didn't understood the second advice :blink: can You explain a bit more detailed? i didn't understant what to look for

thanks

Link to comment
Share on other sites

ok have a look at this pic

Ellen3.jpg

you can see 2 small black hoses below the throttle assembly

you want to check that these and any other hoses in that area are on their fittings properly and that the hoses are not cracked / split anywhere.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...




Forums


News


Membership