Recommended Posts

keying ignition switch does not always crank engine;

sometimes solenoid or relay clicks; sometimes no sounds at all; courtesy and dash lights stay lit when this occurs. After several attempts, cranking occurs. (engine starts). Tried changing batteries/cleaning cables, to no avail. Is it ignition switch or starter. Help! Also, how is starter removed from engine/car ..............

Share this post


Link to post
Share on other sites

I had this problem. My engine was removed prior to the chassis being straightened and when it went back together the starter had a mind of its own. I traced it to the connection on the motor itself being loose. Its not easy to get at but its easier if you swear a few times first and down a few beers. Check it out before you part with your cash. As you know, the cars are virtually bombproof so its probably something daft. :)

Share this post


Link to post
Share on other sites

Have not had this problem on my GS but have on an earlier car.

Take a look at the earth cable between the engine unit and the chassis. If you can, check the resistance between the Battery negative and the engine.

The Battery negative and the engine are each connected separately to the chassis separately as the engine is on rubber (isolating) mountings. A poor earth connection to the engine will cause the probelm your are experiencing.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this