Do Not Sell My Personal Information Jump to content


Squeeky Supercharger


Recommended Posts

For a few days I have been driving around and notice a squeeky little sound coming from what sounds ike behind the top console. It happenes when the car is warmed up a bit and when you rev the engine to about 2000rpm. When your driving normally you cant hear it. Only when like pulling away at traffic lights in the low down gears.

I turned off the engine and if you pat the top of the Supercharger I am able to replicate the noise. Its like a tiny little rattle at low revs. Could this be the cradle?

Link to comment
Share on other sites


For a few days I have been driving around and notice a squeeky little sound coming from what sounds ike behind the top console. It happenes when the car is warmed up a bit and when you rev the engine to about 2000rpm. When your driving normally you cant hear it. Only when like pulling away at traffic lights in the low down gears.

I turned off the engine and it you pat the top of the Supercharger I am able to replicate the noise. Its like a tiny little rattle at low revs. Could this be the cradle?

check the rear support bar to the cradle

is prone to cracking

Link to comment
Share on other sites


or common guys your all to slow

it could be covered, but im not sure, mine was when it broke, but i had mine fitted by TTE, on mine the bolt that holds the brace to the head came out and the bar broke off.

if the same has happened to you, and its not fitted by TTE i cant see why they would replace it.

why would TTE warrenty it, they never fitted it, or supplied it :excl:

however

i doubt the bar is that expensive, €10 at most

Edited by Monster-Mat
Link to comment
Share on other sites

If its the cradle am I covered by warrenty with TTE :unsure:

Surely if it was snapped wouldn't it rattle like crazy say like when I floor it?

should be covered

however its not that essential and is a lot easier just to take off

Link to comment
Share on other sites


Did yours make the same kinda squeeky rattle?

Like what prompted you to inspect it initally?

nope funnily enough, mine fell off on the nurburgring :D which is only an hour from TTE

Edited by Monster-Mat
Link to comment
Share on other sites

It only seems to happen when the engine has been running for a while like if you go for a drive for about 5 mins and then stop at lights you can hear it whn you lightly rev the engine. It doesn't do it when the engine is cold.

I was just out with the car there a sec ago and slapped the unit with the palm of my hand and it doesn't do the squeek like earlier on when it was warm.

Link to comment
Share on other sites

spoke to Owen and he reports back that there is a fracture where the brace meets the frame.

Could possibly be that the brace rod was a mm or two short and under heat and expansion tightened up too much.

It doesnt sound like it has sheared just a small fracture, so is possibly repairable with a re-weld.

either way it is in the upper section of the cradle and not part of the main bolting structure.

Link to comment
Share on other sites

The problem is that its not right from the start, it should have been heated-up and bent round a little when it was fitted (all the ones ive seen have been the same) if you dont do this, this is what will happen, it did the same on aido's car. just weld it and it will be ok :D

Link to comment
Share on other sites

tte have said it doesnt matter too much if it is not on

In my install the bolt at the cylinder head (at the back near the firewall, that normally only holds a hose/cable support bracket) wasn't quite long enough to catch the thread with the extra brace fitted underneath - we ruined the aluminium thread :crybaby:

But, no problems so far leaving the brace off, though.

RX-Men-8

Link to comment
Share on other sites

**********PROBLEM SOLVED**********

Well took the car to an engineering firm this afternoon and what can I say they did absoloutley everything! I was prepared to strip off the SC induction pipe, and remove the SC bypass pipe, and remove the brace, but they did the whole lot. Stripped it, welded it, powdercoated the weld, and put everything back together again. They disconnected both terminals of the Battery as there is a risk of frying electronics when welding. The guy said something like it can reverse the polarity of the Battery if the terminals are left connected while TIG welding. I didn't fancy forking out for a new ECU so disconnecting the Battery was the first job!!

They removed the brace and when the took it away the little piece which the brace connected onto at the cradle came away too, surprise surprise. They used sandpaper and sanded down the area on the cradle where the piece broke away and then TIG welded it onto the cradle. They opted for a TIG weld as it is a much more substantial weld than a MIG weld. After the weld had cooled, they actually took the trouble to go and spray it with a black powdercoat paint. It was a nice touch and you'd never even know know that a repair was done. Just as a matter of interest, the welder commented on how shoddy the original weld was! So anyone else out there with the SC, it might be an idea to check the weld at this point, as if it was as weak as mine, you'll be in the same boat as I was with that very very very annoying rattle.

Dont know if people are interested but I took a few photos of the repaired weld.

CRACKED WELD

P1220001.jpg

TIG WELDED REPAIR

P1230005.jpg

P1230006.jpg

P1230003.jpg

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...




Forums


News


Membership