Sign in to follow this  
Paul J

My Ls400 Doesn't Like The Rain!

Recommended Posts

Hi all,

has anyone experienced engine "plucking" when driving in the rain.

I know it may sound daft but my '93 LS400 series 2 really would prefer to stay in the garage on wet days.

The plucking is most noticeable around 40-45 mph but when I accelerate on it seems to improve although not as smooth as driving in the dry.

Being a complete duffer with engines it seems to me something is getting damp - but what!

Any thoughts?

Cheers,

Paul J

Share this post


Link to post
Share on other sites

If it's misfiring in damp conditions, suspect plug leads and or distributor caps.

Yuo could try spraying the leads and dizzys with a sealant for the job......your local Halfords or the like will know......

Share this post


Link to post
Share on other sites

it should run better in the wet air has its more heavy and it can but more air and fuel in

but my one jerks about sometimes but only when i come just off the gas a little if i come right off it does not do it

i changed the ht leads and plugs a little while a go it did stop it but today it come back

but the only thing in the rain is trying to stop them back wheels from spinning

matt

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this