Sign in to follow this  
Paul J

Ls400 Oxygen Sensor Problem?

Recommended Posts

Hi all,

I have a problem with my '93 LS400.

As the engine starts to warm up, (3-4 miles), between 16-18K rpm the response gets very "plucky" until I slowly accellerate through. At higher revs the roughness is less noticeable but still there. Also the emmissions smell slightly "eggy".

My mate (a fomer Lexus main dealer service manager) has been in the diagnostic port and identified a Code 25 fault. Using the service manual he then did a basic voltage check on the OX1 and OX2 sensors and found while OX2 showed the correct fluctuations identified in the manual, there was no change of voltage at all in OX1.

He recons because OX1 is temperature dependant the heater element in the sensor is duff.

Any thoughts would be most welcome and if he is correct what should I expect to have to pay for a new sensor?

Paul

Share this post


Link to post
Share on other sites
Hi all,

I have a problem with my '93 LS400.

As the engine starts to warm up, (3-4 miles), between 16-18K rpm the response gets very "plucky" until I slowly accellerate through. At higher revs the roughness is less noticeable but still there. Also the emmissions smell slightly "eggy".

My mate (a fomer Lexus main dealer service manager) has been in the diagnostic port and identified a Code 25 fault. Using the service manual he then did a basic voltage check on the OX1 and OX2 sensors and found while OX2 showed the correct fluctuations identified in the manual, there was no change of voltage at all in OX1.

He recons because OX1 is temperature dependant the heater element in the sensor is duff.

Any thoughts would be most welcome and if he is correct what should I expect to have to pay for a new sensor?

Paul

www.oxygensensors.com - thats where i got mine from for my old LS..you have a choice of universal 4 wire sensors which are dirt cheap, or the proper OEM sensor, both do the job, the universal just requires some extra work on installation, as the wires are probably too long.

installation guide here

http://www.lexls.com/tutorials/EFI/mainoxygensensor.html

price of one sensor is 90 odd dollars,universal is 50 dollars. considerably cheaper than uk prices mate.

does look like your sensors are shot, i had the same error code on mine.

Share this post


Link to post
Share on other sites

Cheers Maneesh,

thanks for the info. Got a quote for 2nd hand sensor with 30 day warranty from UK. They want £96! Think I'll try the yanks.

Paul

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this