Do Not Sell My Personal Information Jump to content


Recommended Posts

I know ive read it on here,but my search techniques must need something else,I developed a leak yesterday,stopped at lights after a motorway run and smoke every where,pulled over and had a look while engine was running,fluid was dripping down the offside of the engine just behind the front wheel,it was power steering fluid and although ive not had chance to do a proper inspection,I.m hoping its this o ring thats mentioned before,steering is/was fine no noise or heavy steering,no rack leaks so hoping it not too expensive a job,when the reservoir is removed is this where the screen ive read about is located???

Help and advise would be appreciated, cheers Ian

ps. If it helps,it only appears to leak when the engines running,does this point to the o-ring or something else,sods law,it happens just before the holiday AGAIN !!!!

Link to comment
Share on other sites


:whistling: Hiya again

any ideas anyone,need to try to find out so I can get any required parts before I leave it at the workshop for repairs,dont want him ordering any bits from lexus and surprising me with a HHHHHHHHHHUUUUUUUUUUUge bill on my return.

Ta peeps. Ian :shutit:

Link to comment
Share on other sites

been on a ramp today and seen where its bleeding to death,its coming out of the input shaft where the steering column connects,is this common ?? cant remember reading about this one ? ive removed the one that was on my old rack (but doesnt leak)to see what the job entailed before attacking the car in earnest,seems its only an outer case with the one seal at the top,seeing as the spare never leaked I'm hoping to just swap the two,should work eh ??then I'll take out the worn seal and see about replacments and parts numbers,it could be used on a thread,there must be people out there that have replaced various seals over time and posting numbers could save a lot of time, good idea,or has it been done before ? right time to get packed,im away to the sun !!!!! :winky: :tomato: the car can have a rest.

Link to comment
Share on other sites


I dont think is common but the records for my motor shows pipes were replaced in 2001 and not cheap through lex

Also a first for me on this problem. I read loads about the LS400 in the last few months on various websites and haven't seen this one.

Link to comment
Share on other sites


also first for this one, though just last month, after replacing the ps pump, there was a small leak at that o-ring on the reservoir. it apparently has stopped right now...

they include that when you get a rebuilt pump as you have to re-use your reservoir.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...




Forums


News


Membership