Do Not Sell My Personal Information Jump to content


Help For Newbie


Recommended Posts

Howdie

Newbie here (well have had my 99 IS200 S for about a year now)

Looking for some help

It seems that the subframe that is holding the drivers seat to the interior is a bit rusted on the left side

Has anyone experience this before and any suggestions on how to remedy it (wire brush and repaint maybe)

Thanks

Irishboy

Link to comment
Share on other sites


If it is just surface rust then you have answered your own question ,just give it a rub down and paint it with a good metal paint .good luck and welcome .

Thanks mudzs for the info and the welcome

I am a bit worried if the rust has compromised the strength of the subframe

Any way to tell if it is surface rust or not?

Link to comment
Share on other sites


to be honest once you start to scrape it of you will know straight away as surface rust will smooth of nicely were as if it has eaten in it will be very pitted ,had this happen on my old renault van (was only three years old) and it snapped the strenghening bar that ran across the seat .if in doubt pop it into a lexus garage (or a paint shop)and ask someone to have a quick look as i am sure they wont charge for advice .

Link to comment
Share on other sites

If it is just surface rust then you have answered your own question ,just give it a rub down and paint it with a good metal paint .good luck and welcome .

Thanks mudzs for the info and the welcome

I am a bit worried if the rust has compromised the strength of the subframe

Any way to tell if it is surface rust or not?

give it a rub !

if it comes off and shows metal, its surface rust

wouldnt imagine it compromises the strength

maybe look at why it has rusted, lift up the carpets and see if there is any dampness, you might find a grommet has come adrift and is allowing water in

Link to comment
Share on other sites


After reading this post, I've just noticed mine is rusting too - will definitely be pointing it out to the dealer when it goes in for a service, I don't think internal rust should be happening whatever the cause, especially now I've seen it's happened to someone else as well

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...




Forums


News


Membership