Do Not Sell My Personal Information Jump to content


Recommended Posts

Hi Guys, My first post on here hoping some of you can help me out.

I have a 1992 LS400 import (celsior) that has developed an intermittant steering problem. The sysmptons of the problem are that the steering goes stiff then slack then stiff then slack when turning large corners i.e. when you have to turn the wheel through a great angle/degree.

I did suspect the UJ might be the problem but this seems ok and as the problem is intermittant I'm guessing it could be a problem in the power steering system, Is there any known faults on this model/year vehicle?

It did lose alot of fluid and it has been fully topped up since and the level monitored all the time and I would say it has gone down a very slight amount, I did read on here that there might be a filter to clean or somthing as it does seem like lack of pressure or something?

Any help and advise would be greatly apreciated,

Thanks.

Gaz

Link to comment
Share on other sites


Hi and welcome to LOC

Another Celsior owner well that makes three now at last!

There are lots of threads on here re PS but did you bleed the system when you lost the fluid?

Here is a link to get you started and a good resource site

http://www.lexls.com/tutorials/steering/

Link to comment
Share on other sites

Hi, cool 3 celsiors...you got air suspension? any idea where the amplifier is in these things mines gone pop. pm me

Anyway thanks for the reply re-the steering, I dont think this is an air lock and pretty sure the system was bled. Is there a filter somewhere on the powersteering system? I thought I read that there is.

has anyone else had any problems with the steering?

thanks again,

Gaz

Link to comment
Share on other sites


hi mate, celsior owner here, mines a 91, and the amps on the right in the boot,got to by removing the side lining,I thought mine was faulty ,no power to the sub-woofer,but before spending ,just try connecting another speaker to the sub wires,my problem was the actual speaker,obtained one that worked from a scrapyard.

the rack can be a problem,mine has more leaks than the torey canyon ( showing my age now ) but on my last bit of work the screen was checked and found to be clean,I'm probably going to have to go for a refurbished rack,mines leaking from where the column bolts on,which i gather is the low pressure side of the system ( please correct if wrong ) and i dont know if this section is leaking because of internal seal wear within the rack,but dont think its included in the overhauling process,it seems to be wear on the actual shaft,new seal didnt cure it. i'll give the garage a ring to see if the filter screen is easy to clean with the rack on.

have fun in the celsior,oh,and mines on air also. Ian

.

Link to comment
Share on other sites

Hi,

Mines a 94 sers2 bought with 38.000 miles on it fitted with coilovers and TEMS

The amp on mine is in the boot mounted on top of the cd changer but depends on whether you have Pioneer or Nakamichi premium sound system as to the amp type.

Might be worth getting a garage to check out the steering as it could be pump problem, rack problem or even suspension ( ball joint) problem.

There are known problems with the PS pump and rebuild kits are available but these faults are normally associated with a leak.

Here is another link which may be of some help

http://us.lexusownersclub.com/forums/index...showtopic=12024

Cheers,

Steve ( 1 of 3 known UK Celsior owners on the LOC)

Link to comment
Share on other sites


if there,s only one filter on the system yes its been checked and was spotless,its not loosing much and its not leaking onto the alternator at least ( costly ) the wear on the shaft i mentioned cant be felt its visible to the eye and i have a spare rack to send off,just not sure if the shaft is included in the o/haul or will it just be seals etc. if so i might have to check out the price for that bit,found a company in the US that includes everything but have now stopped shipping to the uk. cheers steve. Ian

Link to comment
Share on other sites

Cheers for your replys.

re-the amp, dont think its speaker related as they have all gone down? head unit comes on and it searches and everything but no sound at all? damp boot caused it i think as the car stood for a year because of suspension issues.

re- the steering, dont think mines leaking too bad just some slight seepage. I am a mechanic in training and my dad used to be a mechanic so I dont go to garages :) you mentioned the ball joints and I had forgot that I think mine are knackered and this could be the problem its just strange how its intermittent and doesnt effect the whole of the turning just certain spots when turning the wheel.

to be fair this car isnt very well, air suspension is still going down over night due to a leaking air bag, the display monitors have gone black, the ball joints are on the way out, theres a knocking from the rear and the steerings on the *****. The other issues arnt as major as the steering though...well the ball joints are.

I need to look into this filter thing though...

also any of you celsior guys got a special little box that can lower the front and rear suspension seperatly and can lower it to the max? mine has one looks like an add on but it is a genuine toyota celsior control box? also in some of the documentation that came with the car it was once owned by a toyota race team so it seems?

thanks,

Gaz

Link to comment
Share on other sites

air suspension bits can be costly click this link to a US company that ships,not that bad a price considering that theyve probably been on since new,or they do a complete kit,bolt on,to change to coil's.

http://www.arnottindustries.com/part_LEXUS...yid7_pid46.html

ive looked into the suspension lowering kits but there,s always something else in the back ground that i need the cash for,is it same as this ??

http://cgi.ebay.co.uk/ws/eBayISAPI.dll?Vie...A:IT&ih=020

most suspension parts are cheaper from the US and readily available,I,m sure you'll get there slowly but surely,at least your mechanicly minded. Ive just ordered the upper control arms from the 1st link,not needed yet but cant match this price in the uk. cheers and good luck. Ian

Link to comment
Share on other sites

Cheers for the links, I will get there eventually...the box I have isnt like that, the one i have fits in with the rest of the dash and panels well as it has the same style lights and graphics and actually says celsior in the TM name style on it, It has two knobs one to sort the front and one for the rear. I usually have it lower as it stops it feeling like a boat and isnt really any harsher than the normal ride hight, maybe a little bouncier though.

If you find any more info on the screen filter let me know,

cheers

Gaz

Link to comment
Share on other sites

Re - stereo:

If you get no sound at all and the car has stood, if the Battery was disconnected or went flat then the stereo will need the code. I took mine out then put it back and it searched and found stations but no sound... same as yours I think.

If you don't have the code, try the last 3 digits of your vin no, that's often it.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...




Forums


News


Membership